AnsweredAssumed Answered

Assembly not updating with new components

Question asked by Thomas Pethick on Aug 25, 2015
Latest reply on Aug 27, 2015 by Thomas Pethick

Hi all,

 

I've been having issues with composer not updating assemblies correctly (read: at all).

 

I have an assembly that has new components and subassemblies added, and several parts have modified geometry, but when I try to update the assembly in Composer, nothing happens. I have made sure the document settings for 'Add new geometry', 'Delete old geometry', etc. are checked, but still nothing.

 

I've tried exporting a temporary .smg file (shows the new parts when opened in Composer) from SW and updating with that... not working.

I've tried importing directly through composer... also not working.

 

It works fine with brand new assemblies and .smg files I made just to test this specific problem. I can create new files, and update with new parts and geometry just fine, but the existing file that was made a few months ago just won't cooperate.

 

No warning popups / errors / anything that I can see when it's importing / updating, and I can't find any reference to where logs may be stored.

 

Anyone have any idea what could be going on?

Outcomes