8 Replies Latest reply on Aug 5, 2016 9:02 PM by

    "No Preview Available" - another possible solution - FYI.

    Dan Bertschi

      Like many of you, I use the preview function of SolidWorks as one option to help me find files when I'm browsing for something.  Recently starting a new job, with new products to learn, I thought it would be nice to just preview parts & assemblies in an explorer window to get familiar with them.  Using SW2014 SP3.0 on Win8.1 x64, my SW Open file preview nor my Win Explorer preview would work.  I search and tried some of the settings solutions with no success.  Since this was my first time on Win8.1, I immediate suspected it, but couldn't find a solution specific to it in my search...

       

      (drumroll please...)  Enter Cami Florence, of Fisher/Unitech, to save the day.  She had a similar issue with her system, and was tenacious enough to see this issue thru to resolution.  What she found was a missing registry key in Windows caused by update KB3072630.  This has been known to cause several problems, including add-ins, for SW users.  It should be resolved in SW2015 SP4.  Until then, there is a registry fix that can be done, along with a SW Install/Repair, that will most likely return your previews.  Cami clearly stated that this is a reported SW2015 issue.  However, my issue was present with SW2014 SP3 and with Windows 8.1 x64.  So, there may some overlap in the effect of the Win update KB3072630, which I did find evidence of on my computer.  You can search C:\Windows to see if your computer has it.

       

      I hope this helps others get their preview back.

           Thanks again, Cami 

       

      Disclaimer: Don't mess with your Registry, unless you know what you're doing, and don't contact me if you brick you computer, LOL!  Seriously, if you have any doubts, call your IT support professional for help with the following.  You will probably need Admin rights to make Registry changes.  I'm posting this because it was driving me crazy not having my previews, and I haven't seen this solution posted yet.

       

      1.  Click 'Start', click 'Run', type "regedit" in the 'Open' box, and then click 'OK'.


      2.  Locate and click the following subkey in the registry: 
      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer

      Note: If this subkey does not exist, create it. (RBM upper level key)


      3.  In the 'Edi't menu, point to 'New', and then click 'DWORD Value'. (I used DWORD, even though I'm running x64)


      4.  For the DWORD name, type "RemappedElevatedProxiesPolicy", and then press 'Enter'.


      5.  Right-click "RemappedElevatedProxiesPolicy", and then click 'Modify'.


      6.  In the 'Value' data box, type 1, and then click 'OK'.


      7.  Run a Repair of your SOLIDWORKS Installation  (Control Panel - Programs and Features - SolidWorks 2015 - Change and then choose repair)  You may need the DVD & make sure your DVD year matches your install.

       

      You may or may not need to reboot, I always do regardless.  GOOD LUCK!!