3 Replies Latest reply on Sep 25, 2015 2:12 PM by Rick McDonald

    SolidWorks startup failure when double clicking file in Windows Explorer

    Rick McDonald

      First off, I am sorry for the length of this post but I want it to be complete enough to minimize misunderstandings or raise questions that can be explained in this first post.

      My impression is that a setting in SW or the registry is not giving enough time to load the application when it is initiated from double clicking on a file but I don't know if that is correct, where to look or what to look for. I am running SW 2015 sp1.1 (same problem on sp2.1).

      Here is the breakdown:

       

      Initially "sldworks_fs.exe" is loaded and running on computer during initial login (it's in my start file).

      (although I can't see that is does anything since if I remove it or leave it, I still have the same load time and errors) - but I guess this is a whole other subject.

       

      When "Solidworks.exe" is not loaded yet - only sldworks_fs.exe is loader from startup file.

      1.JPG

      When I Double click on an assembly, part or drawing file in Windows explorer I get the following message:

      2.JPG

       

      AND - at the same time - SolidWorks.exe begins to load in the background - never opens on screen (not even the splash screen).

      2a.JPG

      When I click OK on Error messages "OK" button the Message clears.

      Nothing else happens.

       

      When I Double click again on any SW file within a short time (while the first instance of SolidWorks is still showing that it is loading) an additional instance of SolidWorks shows up in the Task manager

      as well as another error message.  This will happen repeatedly, adding instances each time.

      Multiple instance.JPG

      It seems, If I wait long enough that SolidWorks would have fully loaded - maybe a minute or more, then double click a file again it will open the SW application on the screen along with the drawing (I just selected) without error.

      But, it will still show the 2 (or more) instances of SW running along with the sldworks_fs program (and never loaded the drawings, parts or assemblies).

       

      Sometimes (I think after I start SW for the first time after restarting my OS and logging in and trying to load SW by double clicking on the file) If I get the timing just right on my double clicks, so that the first instance is just finishing loading when the second instance loads, I will get another error that states that a Journal can not be opened because another instance of SW is open. When I OK the error message, the part will load and run OK. 

      If I close this part and instance, it will close and show the other (first) instance - and that will work fine from there on. - I can then even open several drawings, parts or assemblies at the same time and they will all open within that instance.

      (However, now that I am trying to figure it out I can't get it to do that Journal error problem).

       

      In the cases where I don't get the Journal error message, I will sometimes get SW to open on the screen and it will operate normally, but after hitting the close Icon on the top right corner of the SW application, all visible instances will close (on the screen) and "one" of the instances in the task manager will disappear.

       

      If I double click on a file to open it again (same or different file) it will load ok and will use one of the existing instances of SW that shows in the task manager, giving the journal error if more than one is in the Task Manager.

       

      When I have only one instance of SW open and then close the file and then the application I will only have the "sldworks_fs.exe" remaining in the task manager as I believe I should (or should I?)

       

      At this point, If double click again on a file it will open SW fine with no errors.

       

      I have not fully figured out all the combinations and timing - it seems to be different at different times.

      I started noticing this after I upgraded from SW2014.

       

      I installed the Update to 2015 on the same day as I installed a new Inventor View 2016 application.

      The first time I noticed the error was after I installed both of these.

      I had not noticed this previous to updating both programs.

      I have Repaired, uninstalled and reconfigured SW and even went from SP2.1 back to SP1.1 and have uninstalled Inventor view and loaded an earlier version and then tried the new version again.

      I have run SW Rx and it found my video driver was old and I updated that and still no fix.

      I even went so far as uninstalling SW completely, removing Inventor view completely,  removing all SW related registry items, cleaned the registry and then fully reinstalled SW and still not fix.

      have cleaned and purged my registry again, tried installing the old Inventor View 2015 program, reinstalled.....

      Any Ideas?

       

      Thanks,
      Rick