10 Replies Latest reply on Jul 15, 2015 6:59 PM by Bernie Daraz

    Drawing template issues: scaling, sketches, line styles

    Dean Baragar

      I know this topic has come up many times, but I haven't seen a post about this specific issue.  I have a DXF drawing template which is scaled as 1:1.  However, as soon as I add a drawing view, the sheet scale changes automatically.  I then have to manually change it back so I don't have scaling issues.

       

      Kind of related to this, in normal 3 view drawings, if I change the main view to flat pattern, then decide I want to change the sheet scale, all the other views update, but NOT the flat pattern.  The main view was set to use sheet scale, but then I change to flat pattern and the view changes to custom scale.  Is there a way to prevent this? We are having issues where our drawings are not scaled correctly when transferred to our CNC people, so I want to make it fool proof.

       

      Thirdly, after playing around with our "DXF" template, trying to get it to stay at 1:1, I somehow changed it so that sketches no longer show up.  Before, when I would insert a flat pattern view, I could see the bend sketches.  Now I have to go to VIEW, uncheck HIDE ALL TYPES and then the bend lines show up.  I tried showing sketches, then resaving the template and sheet format, but it did not help.

       

      Fourthly, how can I change the line type of formed features in a flat pattern?  We had an issue recently where a flat pattern drawing was sent to a laser company and the formed feature was shown (as a different colour in SW but not apparently other CADs).  They cut out the feature.  I realise that we should have deleted the lines, but they have also cut bend lines on occasion.  I want to make these lines output as a different line style so that it is more obvious that they are not cut-outs.

        • Re: Drawing template issues: scaling, sketches, line styles
          Glenn Schroeder

          For your first question, un-check the option shown below.  I rarely use Sheet Metal, so I'm afraid I can't help with the others.

           

            • Re: Drawing template issues: scaling, sketches, line styles
              Dean Baragar

              Thanks Glenn,

              That works for the DXFs alright, but for normal drawings, it is nicer to keep that option on.  Solidworks scales views reasonably well to fit the sheet size and if I unselect this, all views will be set to the scale I set when I saved the file.  We work with lots of really big parts and lots of really small parts, so this option is very nice for that.  Perhaps it should be a document setting rather than a system setting.

                • Re: Drawing template issues: scaling, sketches, line styles
                  Rick McDonald

                  Dean,

                   

                  I have the same type problem as you do with the exception that we use .DWG instead of .DXF, but I think the same concepts apply.

                   

                  I have my settings in System Options > Drawings > "Automatically Scale New Drawing Views" UNchecked as Glenn suggested and that works best for me.

                  However I have to take 1 more step:

                  When doing a "Save AS:" to save the drawing file to a .DWG (or DXF in your case), go to the "Options" button in the save as screen.

                  In the options box, check your "Scale Output 1:1 section" .

                  This often defaults to "Sheet Scale = 1/1:"

                  Try changing it to "View Scale = x/x..."  Where the view scale is correct for your desired view's scale.

                  We only use A size sheets here at my company.

                  If I make a part that is 20 inches long and want it to fit an A size sheet,  I have to scale it 1/3 to fit.

                  If I leave the Option set at "Sheet Scale=1/1" the drawing will look fine and all the dimensions will look correct on my A size paper.

                  However the machinists will be paying me a visit, telling me his cad software is saying I have a part that is 60 inches long because his software sees that the " View" was scaled down to one third so it takes the modeled part and makes it 3 times the size.

                   

                  Give this a try.  If it works there is no way to automatically lock this setting. It's a pain, but every time I create a .dwg that is not 1:1 scale, I have to check this.

                  Sometimes it will default to sheet scale, sometimes to View scale and since there can be several views at different scales you need to specify the correct view size (usually will be the majority of your views).

                   

                  I am not sure this is your exact problem because we just us A size sheets and it might not apply if you have larger sheets but it seems like it is the same issue.

                  • Re: Drawing template issues: scaling, sketches, line styles
                    Glenn Schroeder

                    Dean Baragar:

                     

                    Thanks Glenn,

                    That works for the DXFs alright, but for normal drawings, it is nicer to keep that option on.  Solidworks scales views reasonably well to fit the sheet size and if I unselect this, all views will be set to the scale I set when I saved the file.  We work with lots of really big parts and lots of really small parts, so this option is very nice for that.  Perhaps it should be a document setting rather than a system setting.

                     

                    No argument here.  There are several settings in System Options that I'd think should be in Document Properties.  If that was the case with this one, then you could have a separate drawing template for your drawings that will be saved as DXF.

                • Re: Drawing template issues: scaling, sketches, line styles
                  Dean Baragar

                  I found a solution to the problem of bend lines not showing up.  I don't think it is the cause of the problem because everything worked until I changed the sheet format, but it works, so I won't be too picky.

                  Hide All Types Remains Checked

                  • Re: Drawing template issues: scaling, sketches, line styles
                    Bernie Daraz

                    As far as the scaling issues I think I can help. I never make a drawing to make a DXF flat for the turret, laser or plasma. I right click on the part itself (the surface highlights) and select export to DXF. Select sheet metal (if it is) as the next selection and the part will be flattened and exported to DXF. One small file and never a scaling issue.

                    • Re: Drawing template issues: scaling, sketches, line styles
                      Dean Baragar

                      Update,

                      My coworker who was having the biggest scaling issue did not have the "Scale output 1:1" option enabled.  He claims it never used to be checked and still worked, but we turned on the setting and it works fine now.  It also works using either sheet scale or view scale, since we always make sure that the flat pattern view is set to sheet scale.