4 Replies Latest reply on Nov 2, 2016 2:18 PM by Scott Lyon

    Configure toolbox part

    Jacob Murray

      I am trying to make a single part consisting of a spur gear and an extruded circular disk I have created, however when I add a spur gear from the toolbox, I have no "Configure component" options in the left hand column that allows me to easily select number of teeth and module etc. The only way I can get these options is if I right click on the toolbox part and select "Create part". But then it takes me to another screen and the disk disappears.

       

      I simply want to be able to have the spur gear and disk in the same workspace or whatever you call it, just like I created a disk and spur gear manually without the toolbox, and without having to create an assembly.

       

      Is there a way to do this?

        • Re: Configure toolbox part
          Ron Chappell

          Which version of SolidWorks are you using?

          • Re: Configure toolbox part
            Ron Chappell

            If you are inserting as a derived part there are no functions to configure the part it is only available when creating a new part or when inserting into an assembly.

            • Re: Configure toolbox part
              Matt Peneguy

              One workaround that I've had quite a bit of experience with is to create the assembly with the gear in it then manually go copy the gear out of the toolbox folder "C:\SolidWorks Data\browser\Ansi Inch\power transmission\gears" and run "C:\Program Files\SolidWorks Corp\SolidWorks\Toolbox\data utilities\sldsetdocprop.exe" then select the copied toolbox part and remove the toolbox flag from the part.  Once that is done, you can use the part like any other part and edit it to add your custom collar.

              Even though the above process is cumbersome, it sure beats drawing the gear from scratch.

              • Re: Configure toolbox part
                Scott Lyon

                If you right-click on the derived part in the tree and go to external references a lot of the configurations will show up in a drop-down list. I use that quite a bit for hardware. It seems that only the configurations that have been used in the past show up though. Sometimes I have to open the parent part, set the config I want and save the part. Then that config will show up in my list.