1 Reply Latest reply on Oct 29, 2015 9:32 AM by Gary Westland

    CAD BOM automated export issues

    Wade Lewis

      So I’ve been trying to automate a BOM export in certain
      transitions in our work flow, and it just isn’t working out for me. I’ll try
      and best describe what I’ve done and what I’m trying to do, and hopefully this
      is an easy one.

       

      When a SolidWorks drawing file is sent to the approved
      state, It currently creates a PDF and DWG. I am wanting it to also export the
      BOM data shown below along with the drawing release.

      When the ‘CAD BOM’ is selected in the BOM type drop down
      menu, It displays exactly what is in our drawing BOM, even the hard keyed
      stuff. This is great!

       

      I created an Export Rule telling it to export the XML data
      of the drawings BOM to a designated folder. In this menu, I have tried sending
      them to local folders, folders on the network, and folders in the vault.

      For the type of data I have the CAD BOM selected as that
      seems to pull directly from the BOM table on our drawings. I have also
      attempted this with the ‘Only export activated BOM’s’ checked and unchecked.

       

      I then added actions into certain workflow transitions,
      Type: Export data to XML, Checked ‘Run for files’, and selected my export BOM
      rule that I created.

       

      When I push SolidWorks drawings through these transitions,
      they still generate the PDF’s and DWG’s, but there’s no hint of a BOM data
      export file. Is there something that I’m doing wrong that jumps out at
      you? Is what I’m trying to do even doable? Please help.

       

      Best regards,

      Wade

        • Re: CAD BOM automated export issues
          Gary Westland

          I have been working on this with my VAR and we could only write xml files to a folder on the computer that is running the SQL software.

          We then shared out that folder to allow non-administrator users access to just this folder on the server.

           

          However, when I import this xml file into Excel, the layout is way off. Still working on this...