16 Replies Latest reply on Jun 17, 2015 11:43 AM by Lester Kozavich

    Assembly mating problem. Need help!

    Lester Kozavich

      I have this mating problem that is driving me insane. Look at assembly 2 pic and notice how I have all these parts mated (total 5 parts, 3 rods, 2 3-hole pieces plus the base). You can get a sense of the motion they create, like scissors. The 2 side rods move left and right while the middle rod moves up and down. Now look at assembly 1. I have the exact same setup except the rail where the lower rods are moving is curved at each end. When I start mating the parts and I get to the very last mate, which is mating the middle hole and the middle rod, it won't let me mate them. It says:

       

      "The components cannot be moved to a position which satisfies this mate. Cylinders are not coincentric." or "This mate will over-define the assembly".

       

      I know for a fact these are invalid errors because it works perfectly fine when the rails are straight. So I believe having curved paths is causing the problem or perhaps the way I have mated the lower rods to these paths. I have tried mating these parts in many different orders and when I get to the very last mate, which would make them all work together, I get this error. The way I mated the lower 2 rods to the curved path was by sketching a path along the middle of the curve. I edited the rods and added a dot inside them on the same plane as the sketched path and used "path mate" to mate the dot with the sketch. It is visible in the pic. Also I created the curved paths using "spline" command. The curve is not an arc of a circle. Please help me solve this problem of how I can mate these parts.