10 Replies Latest reply on Jun 16, 2015 2:25 AM by Grega Jerin

    Knitting problem

    Grega Jerin

      I'm trying to knit these surfaces together into one surface - now I have 18 surface bodies. Solidworks won't allow. I was also trying to do it in stages but I didn't succed.

      Purpose of this model is STEP file preparation for import into FEM software for shell element mesh. It is easier to mesh there if surfaces are knitted. I'm not an expert in surface modeling so maybe someone here will know how to do it. Thanks in advance!

        • Re: Knitting problem
          Erik Bilello

          Grega,

          SolidWorks won't allow "T" shaped junctions in knit surfaces. I'm a version ahead of you so I took a screen shot. Everything knit fine until I added Surface-Trim1 (aka Surface-Extrude8).  Editing the feature to add that surface gives the error shown.  I don't think there is a way to do what you want to within SW.

          But, getting it down to just 2 surface bodies may make it easier to mesh than 18, I'm not an expert in FEM meshing, or really much of a SW surface expert for that matter.  Good luck.

          no surface knit.PNG

            • Re: Knitting problem
              Grega Jerin

              Thanks for quick reply Erik. I see now that there is a problem with T junctions and knitting. From what I've found out, there have to be only two surfaces connecting on one common edege for knitting to work. I will try on and find something that will work for my FEM meshing.

              • Re: Knitting problem
                Paul Salvador

                It's possible.. knit the right side, the left side and/or knit both...

                knit1.pngknit2.pngknit3.png

                  • Re: Knitting problem
                    Grega Jerin

                    Thanks for answer Paul. I've tried your method, but when I want to knitt two remaining knitted surfaces together I get this:

                     

                    Knitting1.png

                     

                    Changing knitting tolerance doesn't also doesn't work. Can you attach the file with knitting operation saved, please?

                      • Re: Knitting problem
                        Kevin Pymm

                        Grega,

                        Try unchecking Merge Entities & Gap Control.....I was able to do it as Paul suggests. In fact you can do it in one less Knit if you pick the first Knitted surface when you Knit the second half of Surfaces.

                          • Re: Knitting problem
                            Grega Jerin

                            I got it to work with "Verfication on rebuild" option turned off. But if you check it closely, the middle rib is still not knitted, because the edges on it, which are common to other surfaces, are blue (first screenshot). This can also be seen when I open STEP file back in Solidworks (second screenshot). There are two surfaces - one with all surfaces and second is the middle rib. When I import it in my FEM software, I get good node coupling on all surfaces, except the middle rib nodes are not merged. Anyway, this is better than before.

                            Untitled.png

                            Untitled2.png