3 Replies Latest reply on May 15, 2015 9:46 AM by Marc-Xavier Bilodeau

    Solidworks dimension mode

    Marc-Xavier Bilodeau

      I'm working a lot with .step file, some of them have a random UCS in space. That doesn't bother me too much. The thing is that sometimes, when I insert a view, the dimension mode of a view turns on "true" on its own.

       

      That's a problem because nothing warn me it does.

       

      Anyone knows if there's a way to either make "projected" my default mode 100%, or just have a poping message box warning me that the dimension type is set to "true"?

       

      In my research, I found that guy addin, but maybe it's because he made it in 2009, or I'm just too dumb to install this addin, but SolidWorks won't find it: Drawing View Tattler addin

       

      Thanks for any help end suggestion!

        • Re: Solidworks dimension mode
          Nathan Rollins

          Marcx

          I do not really have an answer for you - sorry.  I am posting only because yesterday for the first time ever, I was dimensioning a part and noticed the value was really wonky.  So I learned that the dim was "true" - I had never before heard of that.  I finally was able to set it to "projected" and everything was fine. 

           

          Two thoughts for you:

           

          1 - I noticed also the the arrow head font was slightly different with a "true" dimension - it was shorter or more squat than the normal arrow head.  So, I think you CAN tell if the dim is true or projected - maybe that is your warning...

           

           

          2 - SWX help says that this is set based on the type of view (aux, projected, orthogonal, etc...) and can be changed in the dim's property manager.  I saw no mention of a setting to control it globally.

           

          -Nate

            • Re: Solidworks dimension mode
              Marc-Xavier Bilodeau

              I never noticed it before! I will use it for sure when I can notice it!

               

              It probably happens when there is a big depth difference between the two snapping points. The dimension arrows are point in depth instead of linearly. The deaper the snapping is, the shortest the arrow will look.

               

              In most of my cases, there is slightly a plate's height difference, and the arrow looks exacly the same. See example:

               

              True.jpg

            • Re: Solidworks dimension mode
              Marc-Xavier Bilodeau

              Of well...

               

              "Thanks for any help end suggestion!"

               

              "Thanks for any help and suggestions!"

               

              I probably made others but that one annoyed me...sorry