23 Replies Latest reply on Nov 20, 2017 8:25 AM by Josh Brady

    Can't open files...

    Chris Scheer

      All of a sudden, I can't open (at least some of) my solidworks assemblies and drawings... Solidworks is crashing on me when I try to open.. I'm getting the attaced message..

       

      Have any of you seen this?  This will be bad, bad, bad if I can't get these files opened..

        • Re: Can't open files...
          Glenn Schroeder

          Have you tried a reboot of your computer?

          • Re: Can't open files...
            Kevin Chandler

            Any error reports?

            Can these same files be opened in eDrawings? (maybe the SW file got corrupted)

            Are there backup files (from before your troubles) that can be opened (to test for corruption since or to use as replacements)?

             

            Cheers,

            Kevin

            • Re: Can't open files...
              Jeff Mirisola

              Opening locally or from the network?

              Can you open the parts that make up the assembly?

              Have you tried lightweight?

              • Re: Can't open files...
                Victor Frauenfeld

                Can someone else at your company open the files?

                • Re: Can't open files...
                  Chris Scheer

                  All good trouble shooting question/suggestions.  I'll let you know...

                  • Re: Can't open files...
                    Chris Scheer

                    So here's what I've learned...

                    It's specific DRAWINGS that are referencing my overall Assembly.  I couldn't open up the overall assembly either, but I had a backup of it.. (thankgoodness).  Even after overwriting the Assembly with my backup, the drawings still won't open.

                     

                    - Rebooting doesn't help.

                    - I have duplicates of all files in question on our server, and my hard drive... The same drawings won't open either place (strange?).

                    - I can open the assembly parts on their own just fine.

                    - I can't try to open up from another Solidworks seat computer (yet) because the other computer in our office doesn't have access to my network location (yet).

                    - The Drawings DO open through Edrawings

                     

                    This all started when I attempted to make a drawing out of an auger screw part (see my previous post) in my overall assembly.  I was having all kinds of problems in the drawing I created with the screw... I was using a "display state" from the assembly, (only showing the auger screw) for my drawing.  I couldn't get anything with to cooperate/work smoothly with the auger in the drawing (I since changed/fixed my screw per a suggestion and it works fine now).

                     

                    I don't have any backups of these particular drawing files, but they won't be too difficult to recreate... Luckily (this time).

                    Does Solidworks have a "Recovery" option?  Similar to AutoCAD?  This would allow you to open a corrupt file, and it would "purge/clean" it while opening.  90% of the times it worked.

                      • Re: Can't open files...
                        Jamil Snead

                        It sounds like the problem was tied to your overall assembly, but it is strange that overwriting it with the functioning backup didn't fix the drawings. Since you mentioned that you have duplicated of the files on your hard drive and the server, maybe you fixed the overall assembly in one location but the drawings are referencing the old broken assembly in the other location? If you successfully open the assembly first, and while it is still open you try to open one of the drawings does it still crash?

                         

                        As far as recovery, SW has two things: backup and auto-recover. These settings are located in System Options > Backup/Recover.

                         

                        If enabled the backup option will keep a copy of the last few saves of each file you edit. You can tell it how many backup copies you want to keep. So if you set it to save 2 copies of each document, then the most recently saved version will be in your working directory, a version if it from the last time you saved will be in the backup folder, and a version from the time you saved before that will be in the backup folder (or in the same location as the original if you so choose). This is useful if you make a bunch of changes and save a file, and then you realize you want to undo the changes. You can just retrieve the backup from before you made the changes. However if you follow good modeling practice and save frequently, then the backups become less useful unless you increase the number of copies to save.

                         

                        The auto-recover is different. This is supposed to be able to retrieve any files that were open when SW crashes and (ideally) retrieve changes that were not yet saved. The success of auto-recover leaves something to be desired. Often you will find that it just recovers a document that matches your last saved version. Sometimes it won't recover anything. Sometimes it will keep prompting you to open an auto-recover document even if you already dismissed the message and are working on the part again. Sometimes it will recover a document and you get all excited and then it won't let you save so then you keep trying for an hour and eventually give up and reluctantly close the document that has all of your unsaved changes.

                         

                        As far as I know there is not any utility to fix corrupted files.

                        • Re: Can't open files...
                          Victor Frauenfeld

                          There is not a "DIY" utility to fix corrupted files. However, in the future, if you have a corrupt file that will take too long to recreate, you can give the file to your VAR and they can send it to SolidWorks. They have the tools to recover a file. Keep in mind, it depends on how badly the file is corrupted as to how successful they will be in recovering it.

                          • Re: Can't open files...
                            Mark Kaiser

                            Have you tried opening up the drawings in 'view only' mode, then right clicking on the drawing after it opens and select 'load sheet'?  This worked for me on a multi-sheet drawing that wouldn't open any other way.

                             

                            I like Ingvar's post to references to check to see if there are any problems there also.

                          • Re: Can't open files...
                            Ingvar Magnusson

                            Chris,

                             

                            Have you tried.....

                             

                            Before you attempt open up your drawing, look at references and see if that makes any sense. Can replace references there if you want.

                             

                            references.jpg

                             

                            Maybe it´s still referencing the "Auger Screw" you had problems with and is halting therefore.

                            • This reply has been hidden. This can happen if the message has been hidden by a moderator, or has been reported as abusive.