8 Replies Latest reply on Apr 22, 2015 9:01 PM by Mike Pogue

    Trouble Naming a Global Variable

    Paul Bryan

      Using Solidworks 2014 SP2 64-bit Educational Version on Windows 8.1.

       

      I'm having trouble creating a Global Variable named "Thickness"

       

      Originally I was trying to create it in an assembly, and I'm not sure exactly what happened to keep it from working but at one point I did name a Sketch Dimension "Thickness" and after that it seems to not accept the name for a variable.

       

      I tried deleting the files associated with the problem, and restarting Solidworks and creating a new Part file with a single sketch containing a rectangle and only one Dimension, and the attached picture shows the result. "Thicknes" and "Thicknesss" do not cause the syntax error in the Equation Manager, only if it is spelled "Thickness" does the error appear.

       

      It seems like some kind of glitch, how can I fix the situation?

       

      I did just complete the Repair Solidworks from the DVD, and restarted the computer but it is still happening.

       

      VariableNameProblem.gif

       

      I am also trying this method with the same result.

      VariableNameProblem2.tiff