6 Replies Latest reply on Dec 17, 2015 12:52 PM by Eric Gernot

    'Database not found' error in Solidworks Simulation

    Madhav Rale

      Hello,

       

      A customer of ours is facing an issue when trying to activate the results. They get the above message. I have done the generic checkups like checking admin rights and making sure the file is stored on a local drive. I have also checked that all simulation files are present in the part folder. There seems nothing wrong in the general setup and placement of things.

       

      Does anyone have any answers on what could be wrong? The one thing I still have to try is repair the SW installation on the computer. 

       

      Thank you for all the help in advance.

        • Re: 'Database not found' error in Solidworks Simulation
          Sam Moffatt

          I am having the same issue. Yesterday I ran a number of different simulation trials (static, modal frequency, random vibration, shock, thermal) and was able to view the results with no problems. Today when I went in to view the stresses and displacements I got the message "database not found" for every study. I did not rename any parts, change anything in the studies including geometry, meshing, or constraints, nor did I move any folders where the results were stored. I simply closed solidworks (after saving everything) last night, and reopened it this morning. I have run many other simulation studies without incident, this is the first time that I have run into this issue. It is particularly frustrating as many of the studies take a great deal of time to solve, I cannot afford to re-run the analyses every time that I want to view the results. The folder with all of the studies and part files is stored on an external hard drive (not sure why that would matter, just including it for background information).

            • Re: 'Database not found' error in Solidworks Simulation
              Jared Conway

              there are a couple of discussions about this

              most common are the causes that sam mentions like moving the results

               

              i've also seen it happen when you run a nonlinear for example and your time steps don't match your plots

               

              both of these are expected and fixable

               

              however there are some reports of this randomly happening and that there is no way to "reconnect the results" or review them manually. no one has ever really pinpointed the reason or been able to reproduce the issue. personally I have not run into this and run simulation quite frequently.

               

              so for now, you may need to rerun the simulations but if it continues to happen you'll need to really dig into the workflow.

               

              I have a feeling that it may have something to do with file saving.

                • Re: 'Database not found' error in Solidworks Simulation
                  Shawn Mahaney

                  I am queuing up to rerun every scenario in an assembly right now because every one comes up with results grayed out and returns the "database not found" message. All the files (SW 2015 SP 2.1) are managed in Solidworks EPDM, and have been in the same folder from the start.

                   

                  There is nothing new here. It's been reported every year for a very long time now.

                   

                  I am also starting a support case, for what good it does.

                  file_listing.png

                  screencap.png

                  dbnf.png

                    • Re: 'Database not found' error in Solidworks Simulation
                      Attilio Colangelo

                      I have not worked with SW Sim off a PDM system but sometimes just getting a reliable database on a local hard drive can be an adventure. One thing I found is that the file path name should be kept as short as possible.  I had a colleague putting their files on their Windows "desktop" and had issues because behind the scenes the path was actually "C:\users..  etc".  I would recommend doing your analysis locally and monitor file names and locations closely by right clicking on on the study  ---> Properties --->. Results folder  and make sure there is something there every step of the way.

                       

                      This has been an issue for years and unfortunately the only solution seems to be to work around it.

                • Re: 'Database not found' error in Solidworks Simulation
                  Ludo Dian

                  Looks like the issue is pretty old (oldest inquiry I found is from 2006) and SW failed to address it yet. When that happens to me, and it does quite a lot, I create a new folder directory and enter it in study Properties-Results folder. So far it always worked.

                  Ludo.

                  • Re: 'Database not found' error in Solidworks Simulation
                    Eric Gernot

                    Hello everybody,

                     

                    It also happens to me frequently. Basically I want to have the part file on a local network server, and the results of my studies are stored on the hard drive of the computer I use. Thus I usually start with a part file on the server, set up the study, save, continue setting up the study, save again.

                     

                    Then pause. And check whether SW has actually saved the study settings. (either close SW or only Simulation and reopen the file).

                     

                    This is important, because after a few hours of work with the part open, our SW (2015 sp2.1) will not save anything more. I click the "save button", it does the same as usual, but when I check, simulation settings are the same as they were 1 hour ago (missing forces, connectors, etc.).... Should I have clicked "File", "Save", same thing.

                     

                    When this happens, the file will accept no new modifications of the studies. I perform a "save as and continue" (if it is an assembly, I will save all required components under a new name), in a local folder (local hard drive), and up to now, had to recreate from scratch the studies that were lost this way, to be able to finish the set up.

                     

                    Back to the initial topic:

                    Today a new thing happened : My part, with four configurations and four basic static studies (one for each config, one load, two bodies, two connectors) showed an interesting behaviour.

                    The part file was on the server (local area, was never lost this week). The simulation results were stored locally. All studies were calculated yesterday, and I was reviewing the results today. The PC and SW were on with the part loaded and Sims open since yesterday morning (almost 2 days in a raw), with many "save" action (but not save as). With Win 7 wanting to install some updates, we rebooted the PC this afternoon, after due "save" of the file, and successful exit from SW.

                    After that, I open the part, and all studies have grey shaded results, with a glorious "Database not found". So I tried all possible mixes of saving the CWR file elsewhere, erasing the other study file from the study folder, changing the name of the studies, here is what I found:

                     

                    1) the "save as and continue" method was able to reattach the results of the first 3 studies to the new file.

                    2) I discovered that study n°4, last created, had not been completely saved (I had to recreate a mesh control), so I was not able to reattach the results because mesh and data were not matching anymore.

                     

                    The "Save as" method is nice, but I can't use it within PDM (takes too much part numbers).

                     

                    Hope this helps. I am writing this while study n°4 (should end tomorrow morning) runs again, my colleagues to whom I had to share the promised results left a while ago.