12 Replies Latest reply on Apr 28, 2015 9:43 AM by Mike Pogue

    slow performance at large assembly mode

    Moh AA

      Hi, I am using a good sepcs workstation computer and I have built a large assembly an I have run it in a large assembly mode but it still not enough and it run very slow. how can I solve this problem because it is a misery to continue like that.

      thanks and have a nice day...

        • Re: slow performance at large assembly mode
          John Stoltzfus

          It may be too late now to help speed it up a lot, however one thing to keep in mind on the next big assembly, break it out into sub-assemblies and work on them.  You can also isolate components or set each component as light weight

           

          • Re: slow performance at large assembly mode
            John Burrill

            You haven't given enough information to suggest a course of action.

            Let's see reports from Assembly Xpert on your large assembly and SolidWorks Rx on your system.

            • Re: slow performance at large assembly mode
              Rollo Cain

              Some things I found in SW performance testing that improves SW performance and reliability:

               

              Change Windows System Properties -

                   - "Advanced>Visual Effects" set to "Adjust for best performance" then select 'smooth edges of screen fonts', now you need to go to "Control Panel\All Control Panel Items\Personalization" and select an 'AERO Theme' in order for SW to work properly with Windows.

                   - "Advanced>Advanced>Virtual Memory" uncheck "Automatically manage paging file size for all drives" and select "Custom size" and enter the "Initial size" to the "Recommended" value listed and the 'Maximum size' value to 'Initial value + 5120MB' (need to Restart computer now)

                   - "Control Panel>Power Options" select 'Change plan settings', for the active selected plan. In next window, select "Change advanced power settings'. In popup window, scroll down to "Processor Power Management" and IF there is a  MIN value option, change the value to 100%. If this is not set to 100%, you will not use full processor capability nor allow processor to switch into Turbo mode.

               

              Hardware considerations -

                   - For all SW w/data manager, there is pinging between SW & data manager going on all the time in order to maintain related version notices & defined relationship & those being defined, which become a significant overhead to SW's ability to respond to user as the solid model get larger. If you can open the part/assys you need to work on & the disconnect from data manager while you do you work then reconnect to check-in & save your work, things go much faster.

                   - The amount of physical memory in the computer should be 2x of the largest set of models you are work on.

                   - SW was not making use of the graphics processor units(GPUs) to do the graphic manipulation prior to 2014 Release, so SW was taxing the local processor & memory space, for any graphical activity. SW 2015 makes even better use of the graphics processor units(GPUs) & memory on the cards like K2200/K4200, so graphics responsiveness is much improved.

                   - Also since SW is single threaded(only can use 1 core), if you have a processor that has more than 4 cores, you should disable the extra cores, in the BIOS, and then the processor clock-rate will increase & improve SW performance. Faster the clock-rate the better, for SW performance.

                   - Also having a local SSD or SSHD(hybrid) drive will help performance, unless your SW is connected to a SW data manage, then they may be of little to no benefit to SW performance, because of all the chatter between SW and the data manager.

               

              Also be ware if any programs your company has rolled out to employees, for security, backup or virus protection, because they may be having a significant impact on your SW performance. May of these applications do real-time file checking and cause delays in the I/O activity of SW or other application you are using.

              • Re: slow performance at large assembly mode
                Brian Riffel

                It would be worth your time to read through this excellant article from Cati. They have certainly done their homework and takes into consideration all factors that have an effect on performance.

                http://files.solidworks.com/partners/pdfs/WP_PARTNER_BOXX_Maximizing_SolidWorks_Performance_ENG.pdf

                  • Re: slow performance at large assembly mode
                    Rollo Cain

                    Brian - Very nice article!  Thanks  Much of the Cati document still applies, but it was based on SolidWorks(SW) 2012. Many things have change since then: Window 7 Updates, new SW releases, processors and processors w/HD graphics, and SSD/SSHD drives. My comments/updates on setting to improve SW performance was based on test data, using 2014 SP2 on a single multi-configurable workstation. Hope this help users be more productive.

                  • Re: slow performance at large assembly mode
                    Moh AA

                    I have find that working on sub-assembly strategy can solve the performance issue, and as well to use many sub-assembly as possible. just to share my experience.