7 Replies Latest reply on May 26, 2015 3:00 AM by Simon Weigold

    Parts in sub-assembly do not update

    Sietse Nop

      Good morning,

       

      I'll start by explaining my set-up;

       

      I recently started modeling a assembly in where i created a single sketch where i input my dimensions, im working from a 2014 version.

      I use the dimensions in this sketch to drive the dimensions of most of my parts in this assembly.

      In order to do this, i created global variables from the dimension of that sketch.

      I then started to insert parts, and i linked the dimension that i needed to be driven to my global variables.

       

      So far so good, it all worked like a charm.

       

      My next thought was; lets expand this even further...

       

      I created a new assembly, inserted the older assembly that i had already created as subassembly

      I created a new sketch in this new assembly i created, and linked some of these dimensions to new global variables.

      I started to modify my earlier assembly, and linked some of the older sketch dimensions to my newly created global variables.

       

      And here is where thing started to give me trouble.

       

      Lets say i update a dimension in my new sketch from 3000mm to 2500mm

      This updates my global variable just fine to 2500mm

      In the subassembly my sketch is also driven just fine to 2500mm.

      in turn this updates my global variable in the subassembly to 2500mm.

      Up to here, this all goes well.

       

      Except that my parts do not update!

      The parts are based on the 3000mm dimension, but when i open one of these parts, THEN they start to update to the new 2500mm dimension.

      I close the part, and the part stays updated.

      But offcourse i dont want to do this for every part...

       

      I do not get any errors, or warnings telling me something is off...

      so maybe you guys can tell me where this is going wrong?

      I tried rebuilding several times, i hit control-Q/R/B several times...nothing changes.

      I tried resaving, but the same thing happens...parts are not updated

       

      What am I doing wrong here?