0 Replies Latest reply on Feb 12, 2015 3:07 PM by Andrew Wilford

    Big difference in time to open x_t file based on SolidWorks version

    Andrew Wilford

      I have been trying to open X_T files with SolidWorks. For some reason, using the same X_T file, SolidWorks 2010 can open the file in about 10 seconds. It takes SolidWorks 2013 and SolidWorks 2015 about 5 minutes to open the same file! There is also no prompt in the latter two versions to create the assembly hierarchy.

       

      I tried disabling all import options like healing and checking and it was no faster. Has there been a change to the SolidWorks kernel since SolidWorks 2013? I thought since the kernel is supposed to be parasolid that this would be a fast import. In SolidWorks 2010, it is, but not the versions that come later.

       

      I also tried saving a newer version of the X_T file from SolidWorks 2013 and reopening it. The results were unchanged.

       

      What has changed which would cause this difference: a 30x slower import?

       

      Thanks,

       

      Andrew