3 Replies Latest reply on Oct 5, 2007 11:54 AM by Paddy Rose

    Space Mouse Plus-serial

    Jim Donnellon
      I have used my space mouse in Inventor for years and love it. I now also use solidworks 2007. I don't like the fact that it automaticly rotates around the origin, how frustrating! In inventor it seems to always rotate around the center of graphics window. Why can't you set it up this way in sw??? I am spending alot of time zoomig in and out with my scroll wheel when I have a 3d mouse, doesn't make sense to me.

      Also when your mouse(regular mouse that is) leaves the graphics area, the 3d mouse also leaves the graphics area. Not to sound like a broken record BUT, in inventor the 3d mouse always controls the graphics area no matter where your regular mouse is. I like to rotate my model when I am searching through the browser with my mouse. Is there a way to make the 3d mouse stay in the graphics window?

      I can program my buttons to work fine but, it never remembers them for the next sw session.

      This has got to be a driver issue since everything works GREAT in inventor.

      Any suggestions would be greatly appreciated.
        • Space Mouse Plus-serial
          Mark Matthews
          I to have your issues with the space ball working in SW. I have written an enhancement request to 3-D Connexion to get them to address this issue, but they don't seem to be interested as the driver updates repeatedly do the same things. The space ball should follow what the mouse can rotate about in my opinion. In SW 2007 I love the fact the mouse will spin around what is near at hand; the Space Ball should take this lead. This is how the ball acts in Pro-E and I can't understand why it should be different in SW.
          • Space Mouse Plus-serial
            Jim Donnellon
            After playing around a bit, I found a setting. Under 3Dcontrol pull down menu in SW2007, click on properties. Under options tab, de-select "Scroll Tree Views". This will keep the 3d mouse manipulating the graphics screen no matter where your traditional mouse pointer is.

            Also under Options tab, in Part/Assembly, If you de-select "Keep in View" the rotation center is allowed to move off the screen. Now I can zoom to end of long part much easier.