9 Replies Latest reply on Jul 3, 2015 2:03 PM by Ron Chappell

    Failed to load sldresu.dll

    Jonny Levelius

      I, and some of my coworkers, encounter this error message randomly while using Solidworks.  We have tried the regedit fix where you rename to "solidworks - old" but this only works for a day or two. 

        • Re: Failed to load sldresu.dll
          Steve Elting

          I'm getting this error today when browsing SW files just using Windows Explorer

          • Re: Failed to load sldresu.dll
            VIGNESH NAGARAJAN


            Hi jonny ,

             

            I have checked in SolidWorks KB about this error. A clean uninstall of SolidWorks and reinstalling it will try to fix the problem rather than renaming it. Kindly try this out .

             

            Thanks & Regards ,

            N.Vignesh

            • Re: Failed to load sldresu.dll
              Michael Wade

              Just downloaded and installed 2015 SP3.0.  Still not fixed.  Unbelievable.  I don't understand how more people aren't experiencing this problem?  I can't function if I can't see the Description custom property as a column in Windows Explorer, not to mention have the Details pane open.  You can easily edit the description of SW files right in Explorer without having to open it in SW.  I've been doing this for years and now I've been neutered the past 2 months.  2015 is hands-down the most bug-ridden version I've used.  Shame on you, SolidWorks (Dassault), for not fixing this.

                • Re: Failed to load sldresu.dll
                  Mark Bannister

                  Same problem.  Issue appears to be in the registry. In HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs there a many many SW dll's with invalid paths.  They point to C:\Program Files\SolidWorks Corp\SolidWorks (2)\lang\english\, but on my system these files are at C:\Program Files\SolidWorks Corp\SolidWorks (2)\lang\english ,  No "english" at end.

                   

                  Actually in there twice : C:\Program Files\SolidWorks Corp\SolidWorks (2)\swVBAServer\lang\English\sldresu.dll, and both here the english shouldn't be there either.

                • Re: Failed to load sldresu.dll
                  Adam Brown

                  My error was calling out the file path of C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\lang\sldresu.dll. There was no sldresu.dll file in that location. To fix it I copied the sldresu.dll file out of C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\lang\english and pasted it in the path the warning called out. So far it has been about 2 weeks with no error and it seems like solidworks and explorer are working togeather again.

                  • Re: Failed to load sldresu.dll
                    Ron Chappell

                    The problem occurs when you have the Preview pane or Detail pane turned on in Windows Explorer relates to SPR 832474 the work around is to turn these off. The SPR has a status of Under review (implemented) so hopefully will be resolved in a later Service Pack. I have seen the issue with the missing thumbnails which seemed to be resolved when install was updated to SW2015 SP3 it required the files to be saved again in that version though rather than retrospectively fixing the problem.