0 Replies Latest reply on Jan 9, 2015 12:14 PM by Jim Sculley

    Internal Component Bug

    Jim Sculley

      I have discovered a new behavior in SW 2015 that appears to be a bug.  I am using SW 2015 SP 1.1 with SW EPDM 2015 SP 1.1 and Windows 7 x64. To reproduce the problem proceed as follows:

       

      1. Create a new assembly, but do not save it.
      2. Insert an existing component in the assembly.  Do not save the assembly.
      3. Create a new internal component.  You can use one of the primary planes in the assembly for the initial sketch plane.
      4. Sketch some geometry
      5. Attempt to make a relation between the sketch geometry and the previously inserted component. You will see something like the following message:

       

      If you click OK the message will appear again.  If you click OK once more, the relation will be applied (but with the ->?) marker and the same error message will appear two more times.

       

      If you then click anywhere in the viewport you will get an error like this:

       

      Note the name of the file in angle brackets.  This is not the name of the unsaved assembly file.  The unsaved assembly file is Assem1.sldasm:

       

      The ‘Assembly’ seems to be coming from the document template Assembly.asmdot, which is our default assembly template.

       

      If you click File…Find References you will have strange results like this:

       

       

      Note the reference to the document template Assembly.asmdot.

      I have done the same test with SW 2013 and it does not show any of this aberrant behavior.

       

      The whole mess can be worked around by saving the assembly before beginning to create internal components.

       

      Jim S.