11 Replies Latest reply on Apr 27, 2007 12:40 PM by Ranga Narasimhan

    Inch symbol for default diemnsion

    Ranga Narasimhan
      Hi,

      While detailing in Inches mode, the dimesnion dont have the inch symbol ( " ) suffixed by default. I have to goto the property manager window each time to add the suffix ( " ) . is there any way (in options) to make all default dimension to be suffixed with inch symbol like 2.3" instead of 2.3

      thanks
      ranga

        • Inch symbol for default diemnsion
          Tony Cantrell
          Add it to your dimension fravorites
            • Inch symbol for default diemnsion
              Troy Peterson
              There should be no need to append all dimensions. There should be a call out in your title block stating that dimensions are either in inches or millimeters, see attachment.
                • Inch symbol for default diemnsion
                  Joe Macy
                  This probably sounds weird, but I think your problem is mysolution.....

                  We have been wishing forever that we could get our dims to defaultwith out the inch annotation (").  We were led to believethat having the (") after the dim was an ANSI standard thus itcould not be changed.

                  Is there really a way to set the default to not include(")?

                  Regards,
                    • Inch symbol for default diemnsion
                      Anna Wood
                      We use the default SolidWorks ANSI set-up found in Tools > Options > Document Properties > Detailing > Dimensioning standard.

                      The default is set to NOT show the ". The " symbol is not shown on any of our drawings.

                      Did someone do some custom programming to add it to all of your dimensions? I have no idea how you could add it if you wanted to in a drawing without some custom code.

                      Interesting... :-)

                      Regards,
                        • Inch symbol for default diemnsion
                          that problem has just come up for me, i have mine set to ANSI andthe inch marks shows up, but i also have it displayed as fractionsand not decimals...  i take it fractional displays will alwayshave the inch symbol?  thanks!

                           

                          Originally posted by: Anna Wood We use the defaultSolidWorks ANSI set-up found in Tools > Options > DocumentProperties > Detailing > Dimensioning standard. The defaultis set to NOT show the ". The " symbol is not shown onany of our drawings. Did someone do some custom programming to addit to all of your dimensions? I have no idea how you could add itif you wanted to in a drawing without some custom code.Interesting... :-) Regards,

                            • Inch symbol for default diemnsion
                              Anna Wood
                              Khoa,

                              That makes sense showing the inch symbol with fractions. I wonder what Joe is showing on his drawings, decimals or fractions.

                              Learned something new today.... Thanks for pointing out the difference with decimals and fractions.

                              Regards,
                                • Inch symbol for default diemnsion
                                  Fractional displays ~will~ always have the inch symbol. However, something I ran across when making the move from a place of employment that uses decimals to a place that uses fractions. If you do not have the Tools>Options>Document Properties>Units...SELECT "Round to Nearest Fraction". I have attached two JPEG Files: (1) A picture of a square I sketched on a drawing. The top dimension is displayed in inches with the inch mark because the dimensional number entered matches EXACTLY to a fraction. The dimension to the left of the rectangle displayed in inches because the dimensional value entered did not match exactly a fraction dimension. In this example, I had turned off the "Round to Nearest Fraction" setting. I also included (2) a JPEG of the settings that need to be checked.

                                  I think this may be what you're trying to ask ??? The inch mark doesn't show after all dimensions if (a) you do not have the "Round to Nearest Fraction" selected and (b) the dimensional value isn't a fractional number exactly.

                                  Hope this makes sense.

                                    • Inch symbol for default diemnsion
                                      Joe Macy

                                      Unfortunately, we want fractional dimensions without the (")notation.  I understand that it is against ANSI standard andas stated before, our title block states all dimensions are inchesunless otherwise noted.  It all boils down to some hardheadedguys that have been doing it against the standard for their entirelives and when a software forces them to adhere to the standardthey get grumpy.

                                        • Inch symbol for default diemnsion
                                          Anna Wood
                                          Joe,

                                          SolidWorks is coded to adhere to the standard that is selected in the document properties. Not sure if custom programming will get you what you need. You may want to post a query in the API section of the forum to see if anyone has some code to remove the ".

                                          Regards,
                          • Inch symbol for default diemnsion
                            Kelvin Lamport
                            It's probably easier to remove the grumpy die-hards.

                            I have never understood why fractions get the " notation, but imperial decimals which can be confused with metric decimals don't.
                            Imperial is the only system I know of which uses fractions for linear dimensions ... so it shouldn't need any notation.