17 Replies Latest reply on Feb 21, 2019 12:21 PM by Kevin Berni

    slow performance issue- highlighting lines in orange

    Tal Mor

      Whenever I even briefly hover my mouse cursor over a body part on the list, SW will cycle through all of the lines in that sketch and highlight them orange. I have turned off the dynamic highlighting and indeed the sketches are not highlighted but it still highlights the bodies which is taking a long time. Is there some way of turning this option off? Many thanks

        • Re: slow performance issue- highlighting lines in orange
          Jim Wilkinson

          Hi Tal,


          See this thread that is listed in the More Like This section in the bottom right of your posting:

          slow performance issue- highlighting lines in orange

           

          First, this behavior is not normal and as you can see from my entry in the above thread, is likely caused by your graphics card/driver. In my post I refer to SOLIDWORKS Rx which can help you troubleshoot to see if you have the correct driver for your graphics card or if it is even supported at all. Another thing you can do is from the first page you get in SOLIDWORKS Rx, there is an option towards the bottom to launch SOLIDWORKS in Software OpenGL mode. This bypasses your graphics card acceleration all together and does all graphics on the CPU instead. If the highlighting problem goes away, then it is most certainly an issue with your graphics card and/or driver and you should remedy that issue.

           

          I saw that you had posted in another thread and that post had suggested turning of Dynamic highlight from graphics view in Tools, Options, Display/Selection. As per the thread I references above, there is another setting that controls dynamic highlight from the FeatureManager tree and this option is in Tools, Options, FeatureManager. However, you should really only consider disabling these options as a last resort or workaround for graphics card/driver issues and instead fix the root cause of the problem. Otherwise, the software is much harder to use with these options off because it is difficult to know what you are selecting and picking in the graphics area can be especially tricky without the pre-highlighting.


          Either way, please post back with the solution to your problem so others know how it was resolved.

           

          Thanks, and good luck

          Jim

          1 person found this helpful
            • Re: slow performance issue- highlighting lines in orange
              Tal Mor

              Hi Jim

               

              thank you very much for the help and for directing me to other relevant threads re this issue.

              as for now i turned off the dynamic highlighting from the FeatureManager and left it on in the Dysplay/Selection tab. this pretty much solves it for me.

              i understand that its not the ideal solution.

              as for the OpenGL mode- it is turned on at the Performance tab and in light grey so i can't turn it off or back on. don't know why.

              my graphics card is Intel HD graphics 4600, with total memory of 1696 mb.

               

              apart from that I have another problem. maybe you could help with?

              after editing a sketch or opening a new one the X and V buttons which were on the top right corner have disappeared.

              i have to double click the screen to authorize and go back to the main screen.

              is this the right place to ask this question or should i post it as a new one?

               

              thanks

              Tal

            • Re: slow performance issue- highlighting lines in orange
              Mark Barltrop

              If anyone who has just done a major version upgrade has the problem of "Use Software OpenGL" reverting to ticked and greyed out as soon as a model (even a new part) is opened, even if it has been possible to untick it with no models open, it may simply be that your customisations (System Options) are incompatible with the new version, and accordingly screwing with your registry settings.

               

              This can happen when you upgrade from a significantly older version and import your personalised shortcuts and suchlike.

               

              The easiest way to find out if this is your problem is to go to the Home page of Solidworks Rx app, and scroll down to "Click here to launch SOLIDWORKS while bypassing the Tools/Options settings"

              If this fixes the problem, you're stuck with renaming the Solidworks registry key (to force the program to create a fresh branch from scratch), then recreating your shortcuts and other system settings from scratch.

                • Re: slow performance issue- highlighting lines in orange
                  Andreas Bovin

                  Hi Mark,

                   

                  As far as I remember, I don't think I have made any custom shortcuts or the like, so the issue seems kind of unprovoked.. My graphics card is on-board (Intel HD 4000), which has been working completely fine up until the latest 2016 release.

                   

                  Anyway, I tried your diagnostics method, and it worked for me. When I opened SolidWorks 2016 using the "Click here to launch SOLIDWORKS while bypassing the Tools/Options settings" in SolidWorks Rx, it ran smoothly and all of the above mentioned issues were solved instantly. Now, I want to continue with your suggestions and rename the registry keys, but I don't know which. Can you help me on how to progress from this stage, and which SolidWorks registry keys to rename? Can I do a fresh installation?

                   

                  Regards,

                  Andreas

                • Re: slow performance issue- highlighting lines in orange
                  David Stallman

                  I had this issue in my Parallels virtual machine.  Switching my virtual machine settings from GPU to CPU fixed the problem and it now runs without issue.  For Parallels, this involves switching from "Better Performance" to "Longer battery life" under Options --> Optimization.

                   

                  Here is the post that showed me this.

                  KB Parallels: How Does Parallels Desktop Work with Mac Video Cards?

                  • Re: slow performance issue- highlighting lines in orange
                    Nick Patzke

                    For my Surface Pro 2017 w/ Intel Iris Graphics Plus 640. I had to ADD A NEW KEY/FOLDER with a DWORD(32bit).

                    I ADDED THE NEW FOLDER (highlighted in screenshot) and added the Workaround DWORD with pictured value.

                    It works!

                    SOLIDWORKSFIX.PNG

                    • Re: slow performance issue- highlighting lines in orange
                      Mohamed Eldaly

                      go to Options > System Options > Display > Selection > Anti-Aliasing  and select "None"

                       

                      fixed the problem for me

                       

                      Anti-aliasing is a software technique to smooth out jagged looking edges. There's hardly a difference when I turned it off, but I'm guessing lower powered graphics cards cannot handle anti-aliasing very well. 

                      • Re: slow performance issue- highlighting lines in orange
                        Mohamed Eldaly

                        Try this to keep dynamic highlighting on, but stop the super slow lag.

                         

                        go to Options > System Options > Display > Selection > Anti-Aliasing  and select "None"

                         

                        fixed the problem for me. Anti-aliasing is a software technique to smooth out jagged looking edges. There's hardly a difference when I turned it off, but I'm guessing lower powered graphics cards cannot handle anti-aliasing very well.