John Burrill

Installing SW15 Workgroup PDM server update when using an Admin image to install clients

Discussion created by John Burrill on Oct 29, 2014

So, this advice applies if your circumstances are the following:

  1. You install SolidWorks 2015 by deploying through administrative images
  2. You install SolidWorks 2015 on the same machine as your workgroup pdm vault

Under those conditions, you have to install the PDMWorks server (not the vault or explorer applications) before deploying SolidWorks to your machine.  Attempting to install it afterwards will cause the Installation manager to error out with the cryptic message: "Installation Cancelled"

I learned this by some miserable turns of fortune

A little background on my set-up.  My company has two seats of SolidWorks on subscription.the vault is installed on each workstation laptop and synched through a cloud service.  This effectively gives us a read-only version of the vault for working out of the office-which we frequently have to do.  We avoid synch conflicts by not taking ownership or checking-in files out when working offline.

For 2014, this arrangement worked out pretty well.  When 2015 came out, I wanted to test it for a little while before going live with it, so, built an administrative image and I installed SW15 along side 2014 and when I did, I opted not to update PDM server from 2014 SP4.0 to 2015 SP0.  If 2015 turned out to have problems, I wanted to be able to back out of it.  I'd tested 2015 in the Beta and PR releases and thought the odds of successful deployment were good, but prudence is the orphan of calamity.  After a couple of weeks, I felt secure making the jump.

So, I backed up my 2014 vault as an added measure of security, went to the Customer Portal and downloaded the installer for 2015 SP0, because it's the only way I know of to get the option to install the PDMserver.

I ran the installer, picked the option to upgrade my vault service, did the download and as soon as the installation started, it errored out-jumping to the post-mortem page where it just said, "Installation Cancelled"  Bugger.

OK, so the installation manager didn't like my intentions.  There are ways around that.  I went to SolidWorks Downloads folder where all the files used to build an administrative image are primed, found the PDMWorks SErver folder and ran the Setup.exe in there.  It looked pretty normal going through the wizard, but when I tried to start the vault service, I got an Error 41 saying the user info file wasn't accessible, then another about the reviision scheme and another and 15 more.

The pattern that emerged was the vault configuration files weren't being read correctly.  These are just little text files that sit in the PDMRC folder in the VaultData folder everyone's familiar with.

So at this point, I'm still saying, Don't panic.  I uninstalled the 2014 pdmserver application and re-ran the 2015 install.  The install finished, but the again the vault wouldn't start.

I figured something had gone south with the 2015 install, so I removed it and modified the installation so that it created an empty vault in a new location.  That vault started up without any issues.

OK, so I went into the Vault Admin tool and redirected the server to point to my company's vault data.

The pdmservice errored out again, and now I'm thinking, I've hosed the files some how.  Maybe the index cache got corrupted in the update.  Reverting to the old cache will prompt the server to re-build it, I reasoned.  When the server reads the version info on the cache file, it will jettosine it and rebuild the catalog.  One file was tripping up the works, I guessed.  I copied the old vault backup, the pdmrc and data folders and overwrote the data files in the new vault.

Error 41.

OK, so let's do this clean, I tell myself, glumly.  It's not expedient to copy 70Gb of files from back-up, so I figured the rest of my day was shot.  I had to delete the new vault, which took 10 minutes, restored the old vault-which took 45 minutes and discover that the PDMservice was going to error out-which took 10 seconds. Error 41.

Then it occured to me, I'd restored a 2014 vault that I was trying to access with a 2015 service.  OK, let's try upgrading it again.  I uninstalled the 2015 pdmserver, went back to installation manager and tried to run it.

"Installation Cancelled"

-go to the SolidWorks Downloads, folder, drill down the the PDMWorksSERVER folder, and run setup.exe from there

-installation runs, launch VaultAdmin, start the service

"Vault Error 41"

Now, I'm getting panicky. If my boss calls and says, "hey we need to update the artwork for the Closed Loop IceZone Ballalst.  How soon can you turn it around," then I've got to explain that I can't do my job because I can't access our files and that I don't know why, yet.  OK, it's time to re-establish my 2014 baseline-the last configuration that I know worked.

I uninstall the 2015 service, download the 2014 installer files and try to run it

"Installation Cancelled"

So I'm repeating the steps of my previous failures, but I'm don't see any other way to beat this.  I run the 2014 setup.exe, launch the service and it errors out Vault Error 770.

After some frantic research, I figure out that a 770 error shows up when you try to install a 2014 service to run a 2015 vault-that in my previous efforts, I had corrupted the vault by partially updating it.
No more half measures.  I have to get back to my 2014 baseline, but the fear is dawning that the corruption took place before I made the back-up of the vault or that it was some deep-seeded system level issue, like bad ACL that was exposed when the 2015 .net framework was installed.

At this point, my conjecture is borderline hysterical and I'm unsure of my sequence of events when I started the install.  It's a horrible thing when you don't know if the problem is the software, the data or you.
I uninstall the 2014 pdmworks server, delete the vault and restore the 2014 vault from back-up again.  I run installation manager for 2014 to install the service, "Installation Canceleld"  I run the 2014 Setup.exe, launch the server and it rebuild the catalog and displays the vault admin application.

Big sigh of partial relief.  I'm still in the middle of an upgrade mess, but I'm not indefinitely waylaid by it any more.  -and at least now, I know why my fallback process is.  If my next attempt fails, I uninstall 2015, restore the vault and re-install 2014 from the setup.exe.  Not pretty, but comforting in how straightforward it is.

OK, so like an absent minded criminal thinking the coast was clear the last time he was caught, I reason, I'm back to a textbook upgrade scenario. It should go the way it's prescribed in the online help.

Start over.

"Installation Cancelled."

But I am Zen at this point.  This is karmic.  I need to understand the events in which I've become enmeshed instead of taking them as a referendum on my worth as a CAD admin.

The next logical step is to try the Setup.exe, but if that doesn't work, I'm going to need the installation logs for my VAR.

Out of curiosity I open the installation log and trace it to the point where it errors out.

"{0: You cannot modify an administrative image installation to become an individual installation.  Install from a new administrative image, or uninstall the old image before performing an individual installation.}."

So it's saying, the installation manager is mad that I attempted to install the pdm server after I installed SolidWorks from an Administrative Image and it's not going to cooperate.  This is usually where I say, "screw the installation manager, I'll run the setup.exe"

But, it occurs to me, if I uninstall SolidWorks and then install the PDMserver with the installation manager and it works, I will know that the one thing I haven't done because it seems like such a waste of time, is categorically required.  I want that knowledge in the bank for my service packs and 2016.  I don't want to just get passed this one snag and push the problem into the future.   I need to know as surely as I know you can't save back to a previous version that you have to install the pdmworks server before you install SolidWorks via administrative image.

You do.

When I ran installation manager, it upgraded the vault from 2014 SP4.0 to 2015 SP0.  I was able to launch the Vault Admin, which came up fully quiescent.  I rebuilt the catalog, just to expose any possible corruption and no issues.  I have a working 2015 vault.

I've just re-installed SolidWorks and now have to reboot the machine before making sure that I've completed the upgrade without issues.  I'll post again soon, but for now, remember the moral of the story:

If you install your vault service on a machine that runs SolidWorks, you have to install it before installing SolidWorks from an administrative image.

Outcomes