AnsweredAssumed Answered

library feature works, but only once

Question asked by Rob Edwards on Oct 22, 2014
Latest reply on Oct 22, 2014 by Rob Edwards

Hi All

 

Im designing a staircase and thought the ballusters would be an excellent opportunity to create a library feature which works out the correct number and spacing of ballusters to comply with regulations.

 

The feature also cuts mortise holes and creates the pegs to hold it all together.  I was delighted when it worked, but then when I tried to use it for the second time it failed.

 

This model has three balustrades and the feature works fine for each of them individually, the problem only occurs when I try to use it more than once.

 

The only clue I have to why it didn't work is some of the equations that the 2nd failed attempt left behind.  There appears to be some irregularity in the way solidworks has renamed the various dimensions and features so its got itself in a right pickle.

 

I have some screenshots below showing what I have described above.  The last one shows the equations which are very strange. 

 

I am going to rebuild the feature from scratch and keep the solidworks defaults for all feature and dimension names, but in the meantime any advice would be much appreciated, I'm making the assumption that this is possible

 

Thanx for reading

 

ps .  its late so i've gotta dash but I just got it to accept a second feature (with errors) the problem is definitely to do with the renaming, as I can fix some errors by manually renaming things.  But its a right tangled mess to unweave - hard to understand the rules solidworks is applying..looks like it's trying to be too clever but ending up being stupid,  just like me sometimes lol

 

 

 

1.png

2.png

3.png

4.png

5.png

Outcomes