3 Replies Latest reply on Feb 16, 2015 9:32 PM by Greg Rupp

    Chinese characters show as white box

    Ty McKnight

      I just installed SW14 SP4.0 on a new Win8 OS. My company uses bilingual sheet formats with English and Simplified Chinese in the title block. The Chinese characters showed up fine on my previous machine and they show on all the other machines in my department. On my new machine, they are all showing as the empty white box character.

       

      So far I have tried installing the both Chinese SW language packs, ensuring Chinese language pack is installed on my OS, and finally updating my .NET framework to the latest version. Does anyone have any other ideas to get Chinese to show up in my annotations? Thanks for any thoughts!

        • Re: Chinese characters show as white box
          Habib Ghalamkari

          Normally, installing Chinese language to your installed language list in Control Panel\Clock, Language, and Region\Language should work.

          But it seems you still have troubles viewing Chinese characters.

           

          Try changing your system locale to Chinese. Go to Control Panel\Clock, Language, and Region and click Region.

          In Administrative tab, click Change system Locale... and select Chinese. click OK all your way out to close the dialog boxes. Reboot.

            • Re: Chinese characters show as white box
              Ty McKnight

              Habib,

               

              Thanks for your thoughts. Oddly enough, it seems to have worked itself out overnight.

              • Re: Chinese characters show as white box
                Greg Rupp

                I ran into this problem today...

                Initial problem.jpg

                So turns out that the language pack helped… but wasn’t the solution. Once the language pack was installed and set to "system Locale" it would display correctly on the screen … everything appeared correct. However, once you try to save a PDF, the file would error out with the following. (Arial Unicode MS error). If you continue to make the PDF, the text that is supposed to be Chinese characters is now completely missing when the PDF file is viewed.

                 

                Arial font Error Message.jpg

                 

                Turns out, you have to have a specific Microsoft font installed. I installed MS Word and Excel (2013) and it now works like other computers. I also uninstalled the language pack and it still works the same.

                 

                Lastly, the Solidworks KB has this issue listed, however it does not list this fix.

                 

                I was installing SW 2012 sp5 on a Win 2008 r2 VMware server to be a PDM host for EPDM.