4 Replies Latest reply on Oct 7, 2014 2:00 PM by Andrew Kronquist

    Sketch error has me stumped

    Andrew Kronquist

      I have a sketch error that I can't figure out. I could just get it done and forget about it, but I would really like to understand this.

      File attached.

       

      SWFC.png

        • Re: Sketch error has me stumped
          Arthur Loginow

          Can you please turn on the relationships and upload a new picture? (To turn them on you just have to go to the goggles at the active screen and search in the left column at the drop-down menu)

          • Re: Sketch error has me stumped
            Jeremy Feist

            it is because the sketcher tries to make the minimum changes to the sketch based on your inputs. and that line happens to be .1" long, so making the .4" into .5", would make that line 0.0" long which is an error in the sketcher. make the line a different length, or dimension its length first, and you won't get the error.

              • Re: Sketch error has me stumped
                Andrew Kronquist

                That seems reasonable enough, but I was really expecting the construction line to increase when I went to .500". In my mind I think SW, given a choice, will do whatever is necessary without generating an error, and that's why I actually removed the dimension of the construction line earlier. Come to think of it, the bottom segment could have increased, too.

                At any rate, it looks like I'm done with the mag mount antenna thanks to everybody's help!

                 

                404237_antenna_1024.png

              • Re: Sketch error has me stumped
                Arthur Loginow

                Andrew, if you want to modify the .400 line, then you will have to add a dimension to the mid line (the small one, the one that you are having the issue with) otherwise it will not recognize a specific size and you will get that error, it is because you will have an entity with no length, see the distance of that line is .100 but is an implicit length not an explicit length, therefore if you add .100 to the .400 line you will have a 0.0 entity, that is the error you are getting, just add a dimension to the mid line and you will be fine