3 Replies Latest reply on Oct 10, 2015 1:30 PM by Jamil Snead

    Scaling Problems When Creating Blocks

    Brian Hughes

      Hello all!

       

      I have a small detail that I include with a lot of drawings, and it is made up of a simple drawing view with a few notes. However, I am experiencing interesting results when I try to make a block from the drawing view and notes.

       

      When I create the block from the view using "Convert View to Sketch" --> "Insert Block", the block that is created immediately doubles in size (see the picture). I have no idea why it does this, but I want the created block to be the exact same size as the original drawing view (again, as seen in the picture). The weird thing is that I created this same exact block before (a few months ago) which resulted in the block I want per the picture, but I don't remember having to deal with this behavior...

      Block Scaling Problems.png

       

      These are the steps I follow:

      1. Right click the view --> Convert View to Sketch.
      2. Select "Insert as a block"
      3. Click green check mark
      4. BOOM! The created block appears, and it is twice the size it should be.
      5. Click to place over-sized block in hopes that it will scale back down to the size of the original drawing view.
      6. Get frustrated that the block decided to stay twice the size it's supposed to be.

       

      Couple of notes:

      • The view scale of the original drawing view is the same as the sheet scale.
      • I do have some hidden layers on the drawing sheet format, including some dimensions on a hidden layer, but I have already tried showing the hidden layer and deleting the dimensions, to no avail.
      • I've also tried using a completely different sheet format, deleting the unused layers, and still nothing changed.
      • I have also tried using the "Replace view with block" option, as well as "Replace view with sketch" option followed by using either "Replace view with block" or "Insert as block" on the resulting sketch. None of this has worked either.
      • I could use a workaround to get it to work... The workaround is basically creating the block the same way as above, but before clicking to place the block, setting the scale to 0.5. After clicking to place the block, save block to external block file. Then, when inserting the saved block into another drawing (or even the same drawing), it appears the correct size, though it is just automatically scaled to 0.5. But, I feel like I shouldn't have to do that, and that I didn't have to do that when I made this exact same block a few months ago.

       

       

      So, when you guys create blocks in drawings, do you notice this behavior? Or do your created blocks stay the same size as the original drawing view?

       

      Is there some option I have turned on that is causing this behavior?

       

      I attached a zip of the original part and drawing files for you guys to mess around with and see if you get the same behavior.