AnsweredAssumed Answered

Phantom regions when extruding

Question asked by Loren Sackett on Sep 8, 2014
Latest reply on Sep 10, 2014 by Jerry Steiger

I start by making a sketch with multiple regions on an existing surface.  Then I try to extrude the sketch (boss or cut) and SolidWorks will use edges on existing surface to add extra regions to the extrude.

 

In the picture I have attached, the sketch on the existing surface contains only 2 circles - which make 3 regions.  When I try to extrude, SolidWorks creates a 4th region that is not part of the sketch.  On complicated sketches on complicated surfaces this can be REALLY annoying when I make changes and have to keep fixing all of the phantom regions that I never wanted in the first place.

 

Is there a setting where I can change this behavior?

 

phatom regions.png

Outcomes