5 Replies Latest reply on Jul 17, 2014 4:07 PM by Greg Welch

    Part keeps disappearing

    Greg Welch

      I've been seeing some strange things when I try to create a drawing of a particular part.  When I insert the part into a border, the part insert and creates views fine.  When I save it and reopen it, the part has disappeared.  The views are replaced by the box you get when a drawing can't find a part, although the alert warning about that doesn't pop up when I'm opening the part.  If I right click on the box, the part that should show there opens up, but in the area in the top center of the part window where the part name is displayed, it displays it without the customary file extension (i.e., .sldprt).  See the screen shot.  Finally, when I save the assembly or the drawing the part is located in, Solidworks keeps asking me if I want to save.  Has anyone seen this before?

        • Re: Part keeps disappearing
          Greg Welch

          To clarify, when I stated that "Solidworks keep asking me if I want to save", I meant it was asking me to save the part, and it did it in the way it would as if the part had not been given a name before.  That is, it opens the file directory dialog box.  When I tell it to save the part with the name the part already has, it acts like I'm overwriting an existing part.  If I decline to save the part, it comes in suppressed the next time I open the assembly, though the part shows up as soon as I unsuppress it.

            • Re: Part keeps disappearing
              Deepak Gupta

              Is the save folder located on a network drive?

               

              Does this happen with all files OR some files OR this file only?

               

              If there any in-context relation for this part?

                • Re: Part keeps disappearing
                  Greg Welch

                  The save folder is on a network.  The part in question and a part I created from it are the only ones I have trouble with.  There's no in-context relation with this part...however, it may have been made from a part that at one point had an in-context relation.  I can't recall if I edited an existing part to get to the part I currently have, or if I just started fresh.  The part as it currently exists does not have any in-context relations.  It currently is a very simple part, with no exotic features, just the standard extrusions and holes.

                    • Re: Part keeps disappearing
                      Deepak Gupta

                      There may be a possibility that network might had broke while you were doing some changes, etc. So that might be the reason for the save as pop.

                       

                      It had happened to me in the pat so that is why I ask if the path was network folder. If it is doing again, then check if your network path is accessible OR not. If everything is OK but still it troubles you, then please report to your VAR.