2 Replies Latest reply on Jul 10, 2014 10:21 PM by Rejo Jayaraj

    weird behaviour of GetSketchPoints2

    Rejo Jayaraj

      hello friends,


      I am facing an trouble when I use GetSketchPoints2. I have a sketchsegment created using usededge refrenced from a different sketch. Then I create a line passing thru the center of the first sketch segment. Then these two segments are trimmed ot obtain an L shaped contour, of which one of them is usededge and another one is created line. When I use the GetSketchPoints2 or GetSketchPointsCount2 to get all the points or number of points in the sketch, I get number of points as "4"  even though there are only "3" points. I tried the script with various other sketch i still get some error in the count of the points.


      But this issue doesnt exist if two created lines are trimmed. Could someone help me to resolve this issue or has anyone come across this issue?


      sketchPointArray = theSketch.GetSketchPoints2
      pointCount = UBound(sketchPointArray)

      MsgBox pointCount
      MsgBox theSketch.GetSketchPointsCount2


      Thanks & Regards,

      Rejo jayaraj