3 Replies Latest reply on Jul 2, 2014 4:28 PM by Jeremy Feist

    Find and Replace Text Issue...

    Craig Ashmore

      I'm having an issue with the find and replace text feature. When I try to replace a certain piece of text within a note, instead of replacing it, it puts it in at the beginning of the note.  See attached pictures

       

      Before Replace.jpg

      After Replace.jpg

       

      All the text show in the pictures with the exception of "TITLE:" is contained within one note.  I realize that these should ideally be linked to custom properties which would make changing these alot easier but these drawings are from and old project before we wised up and started using custom properties.

       

      Thank you in advance for taking the time to assist me in this matter.

        • Re: Find and Replace Text Issue...
          Deepak Gupta

          Sorry to bog down with question but is this for one drawing OR do you need to do it for several drawings? Can you try this on a different drawing or machine?

           

          Can you try replacing a different note and see what happens? What SW version you're using current? Can you share a sample file to test?

            • Re: Find and Replace Text Issue...
              Craig Ashmore

              No worries, I'm past the point of being bogged down. Ha

               

              It is for several drawings and I've generated a macro to perform this as a batch operation, but when I noticed the error, I investigated it by using the utility within solidworks manually and still incur the same issue.

               

              I've tried numerous drawings and 2 other machines with the same result. Within the code I have it finding and replacing other characters with no issue. Although this is the only annotation-note that contains multiple lines which makes me believe that has something to do with it.

               

              I further tested it by trying to simply replace "SAMSON RESOURCES" with a different set of characters and got the same result.

               

              Also I tried to perform this as well: Find What: "SAMSON RESOURCES MARAUDER 2413-1H/MARAUDER 2413-3H"

                                                                Replace With: "SAMSON RESOURCES STINGRAY 1819-6H/CHARGER 0706-8H"

              and got again, the same result.

               

              OK now I'm really puzzled....I was preparing a sample document for you by just opening one of the drawings that I'm having this issue with and deleting proprietary information (I cannot give out anything with information as we are under strict design contracts with the customer) and after doing so I ran the find and replace within Solidworks to make sure you would get the same result, and bam it worked like it was supposed to. I realize its hard to troubleshoot something like this without working directly with the file but my hands are tied on giving anything out.

               

              Thank you again for taking the time to look at this and help me with this problem.