AnsweredAssumed Answered

Unable to view Solidworks file types in File Explorer?

Question asked by Julia Hartig on Jun 24, 2014
Latest reply on Sep 21, 2014 by Andrewop Pit

I've been having problems viewing the file type (SW part, assembly, etc.) in file explorer. I'm using my company's PDM server, and for whatever reason it will list the type of file under "file type" for every kind of document (TIF, DXF, etc.) except SolidWorks ones. At the very beginning, I didn't have this problem. Then, it would list if a file was a SolidWorks part or assembly (although it wouldn't categorize drawings), but now it won't list any of them at all. It even hides the file extensions (.sldprt, .slddrw, etc.) which is especially frustrating when I'm searching the database for a specific file and can't organize my results by file type.


We tried going into Options -> System Options -> File Explorer in SW and clicking "Restore file associations", but this didn't seem to make any difference (even after it was done with administrator permissions). This seemed to happen shortly after we tried to fix a "can't double click in file explorer to open a SW file" problem by having the default opening program be SW Launcher instead of just normal SW. We tried to change it back, switching the default program back to the SolidWorks exe file, but now it won't let us do that either (no error message, it just doesn't work). Any advice?