9 Replies Latest reply on Jun 18, 2014 5:09 PM by Jeff Mirisola

    snapping to model reference geometry - 2014

    N. Ritchey

      i am a new user to 2014, having years of experience with 2010 and 2012. setting up my  new work computer i'm experiencing something odd that doesn't feel correct and i couldn't find any information about it on the internet.

       

      a habit i picked up from using pro/e wildfire is to always have my datum planes visible by default -- i will turn them off manuall if i need to. so when using SW2010/2012, i've always just had my Front/Top/Right planes visible by default. this was never a problem.

       

      now in 2014 i'm having this issue where, during sketching, my lines will ONLY snap to the planes if visible. other snaps will override this (i.e. snap to 45 degree angle, snap to coincident with an existing point), but other than that, lines will snap to the planes and nothing else.

       

      in the options>sketch>relations/snaps if i clear "snap to model geometry" this issue does not occur. unfortunately this also removes the ability to snap to typical model reference geometry. let's face it -- snapping to planes is useful.

       

      just wondering if this is a known issue or if there is another new 2014 setting i'm missing that will help me out. the only other workaround i have is to use my key binding to disable plane display while sketching. in other words: no visible planes while sketching.

       

       

      -nsr

        • Re: snapping to model reference geometry - 2014
          Jamil Snead

          I don't quite understand your problem. Do you want the lines to snap to planes or not? Are you saying you want the lines to snap to hidden planes?

            • Re: snapping to model reference geometry - 2014
              N. Ritchey

              when i say the lines snap to the planes i mean that they snap to the planes and ONLY to the planes. you cannot click into free-space to place the endpoint of a line. if you do, it snaps to the nearest plane.

               

              so imagine drawing a square starting on the origin -- you click on the origin (check), drag the line out to the right and click on the horizontal plane (check), then drag the next line up vertically out into open space. here is where there is a problem.

               

              if you leave the planes displaying, the line will ONLY snap to either the vertical or horizontal plane

              if you hide the planes, you are free to place the endpoint in any position (which i feel should be the default action)

               

              basically i want the lines to snap to planes, IF i'm intending to place a point on a plane. on the other hand, if i'm intending to place a point out in space, not on a plane, i should also have that option.

            • Re: snapping to model reference geometry - 2014
              Brendan Lindaman

              This "bug" is affecting me as well.  I have used every years version of solidworks since 2008 and this never worked this way until 2014.

               

              I, like Ritchey, like to draw with the planes "shown" instead of "hidden" like they normally are.  But now, for example, when i start a line in my sketch at XYZ 0 (origin) I can ONLY go vertical or horizontal on the other two planes.  I have been working around this by starting off of the origin drawing the shape then dragging it back to origin afterward which is a pain.  This never happened before and any of the previous versions of solidworks. 

               

              I hope they can fix this.

                • Re: snapping to model reference geometry - 2014
                  N. Ritchey

                  yeah i am also starting to think this is a bug. i don't know if it's 2014-wide, or isolated to certain installs (i haven't had an opportunity to test on a coworker's install but will when i get the chance). i was hoping that it was a setting i had accidentally set incorrectly but now i guess i'll just have to work around it! not the end of the world, but frustrating.

                   

                  also this only happens when using the line tool. sketching shapes such as circles or rectangles do not cause this glitch.

                   

                  i've also attached a short video clip of the problem. in the video i attempt to create three sketches 1) using the default template with no planes visible 2) with planes visible. notice how the line tool does not follow the pointer, and lines are created at what appear to be random points and 3) with planes visible, sketching with the rectangle and circle tools. no issues.

                   

                  when i get a chance i'll test on my coworker's machine and see if the same thing happens. if this is a solidworks 2014-wide issue i'd like to see it resolved. if it's an issue with a few unlucky installs then... well... i guess i'll have to work around it!