AnsweredAssumed Answered

Incorrect description of toolbox part

Question asked by MS B-G on Jun 12, 2014
Latest reply on Oct 7, 2014 by Luis Rivera

Hi,

 

I am having a problem with my toolbox. First, I tried to generate a custom toolbox that only contains certain toolbox componnents by duplicating the ANSI inch folder and renaming it. This did work. After, I wanted to modify the description associated with the toolbox componnents so that when I generated a BOM it would display the description I wanted (ex: instead of displaying preffered narrow flat washer 0.25, I wanted to display STEEL FW 1/4" SAE). To do that I used the import/export option in excel to add the description I wanted in the empty description column, had no problem doing that. Now, the washers, split lockwashers and hex nuts are displaying the description I entered and that is perfect, but it never worked for any type of bolts (I have never succeeded in having the bolts display the description I tried to set them to). After a while trying to find what was different/what I had done different than what I have done with washers, I gave up and decided to live with the default solidworks description (filename) for bolts so I deleted all the custom descriptions I had tried to give the bolts (so now the description column in the toolbox configurator is empty.

 

This is when I noticed something on hex socket head cap screw and the hex socket flat head cap screw. When I inserted a new bolt in an assembly using the toolbox, it would create a part named after the dimension of the bolt I had just created, but if I opened it and checked in the properties, I would see a custom property named description and it would always display the same thing (for example: SCHCSCREW 0.25-20x1x1) regardless of the size of the part. Even if I called, for example, a 3/4-10 x 10" bolt, it would always display SCHCSCREW 0.25-20x1x1 in the properties (and in my BOM). So I openned the root file for hex socket flat head cap screw (toolbox parts>browser>ANSI INCH_2) and saw, under proprties, that there was a description custom property. So I deleted it and this solved my problem for the hex socket flat head cap screw. I went to do the same thing for the socket head cap screw but it never worked. Whathever new socket head cap screw size I create, it still always display the same size (0.5-13x2x2) under the description property (and in my BOM).

 

I dont know if this could be related, but in the toolbox configurator, I removed all drive types for the socket head cap screw except the hex one, but when I want to insert a new socket head cap screw into an assembly, I still have the option to select the other drive types (that I removed in the toolbox configurator).

 

If anybody has ever encountered this kind of problem (improper description for a toolbox componnent) or have any idea of something I could try to fix this it would be greatly appreciated. And if there is no way of fixing this, is there a way to uninstall the toolbox and reinstall it to see if the problem persists? I would not mind having to redo my custom configuration names for the washers, lockwashers and nuts if it solves my problem...

 

Thanks to anybody who could help me or just point me in the good direction to fix my problem!

 

P.S. I hope I'm clear in my explannations, english is not my first language.

Outcomes