5 Replies Latest reply on Jul 1, 2014 2:32 PM by Pam Johnson

    Promote command STILL not fixed

    Greg Welch

      I'm having a problem getting my ballons to match what's called out in my BOM when the "promote" option is set for a subassembly.  When my BOM is set for top-level only, the balloons call out the assembly names of subassemblies, as they should.  When my BOM is set for parts only, the balloons call out individual parts within subassemblies, as they should.  When my BOM is set for top-level only, and some of the subassemblies are set to "promote", the BOM works fine, but the balloons still call out the assembly names of all subassemblies.  Am I overlooking something?  I would have thought they would have checked this function when they "fixed" the promote command.  I'm using SW Premium 2013 x64, SP5.0.

        • Re: Promote command STILL not fixed
          Pam Johnson

          This is also a big issue for me . . . don't know if the only solution is to fill the balloons in with text and risk human error?  We just got Solid Works, (2 weeks ago) and if I'm going to have to skip using assemblies within assemblies, it is going to add a great deal of time over something that seems so basic (having the balloons match the BOM).

            • Re: Promote command STILL not fixed
              Greg Welch

              You can still get things to balloon properly with subassemblies, kind of.  Set your BOM to show parts.  Set any subassemblies you want to call out as a subassembly to hide, and set the rest to show.  The parts in the subassemblies set to show will show up fine.  However, to call out the subassemblies set to hide, you have to balloon on the origin point of the subassembly.  If you want more information on that, let me know.  I don't want to type it out if I'm telling you something you're already familiar with.

                • Re: Promote command STILL not fixed
                  Pam Johnson

                  Greg, thanks so much for your help!  I believe I have followed what you are describing, and I think I've got the BOM responding correctly, but I'm having trouble with the step of ballooning the origin point. I selected "show" in the design manager tree, but it doesn't appear to show up (the icon in the tree shows blue now, but still can't see it in the model)?  I tried RMB "go to selection" and it zooms out instead of in.  The subassembly I am trying to get the origin for is 110 feet long, so don't know if the size is the problem, or ifthere is some trick to zone in & select the origin when placing a balloon?

                    • Re: Promote command STILL not fixed
                      Greg Welch

                      Where you need to have the origin show up is in the assembly drawing.  You turn the origins on and off in the View pull down.  You can also select it under the "eyeglasses" icon in the View toolbar just below the command manager.  When you turn the origins on, you'll probably have to do a rebuild to get them to show up.  Once they show up, you attach the arrow of the balloon to the origin you're looking for.  You can turn the origins off after you're done without hurting anything.  The first problem is, when you turn the origins on, EVERY origin of every part and subassembly will appear.  So you will need to find out where your origin is, especially if you have a complicated assembly.  It kind of sounds like you're saying you can't find the origin on your model.  It is at the intersection of the three main planes of the model.  The second problem is, it's not unusual for a subassembly to have an origin at the same place as one of the parts in that subassembly.  So, when you place the balloon, if the origin you select gives you the part number instead of the assembly, right click and click on the Select Other option.  That drops down a menu listing your options.  Something I've never tried, but might work, is to hide any part that has an origin at the same place as the subassembly origin, then show it again once you've made the selection.  The third problem is, the origin may not be in a really great spot for ballooning.  You may have to reposition your assembly relative to your planes to get the origin to a better spot.  Remember, the origin is at the intersection of the three planes.

                       

                      Try this.  If you need more help, feel free to ask.

                        • Re: Promote command STILL not fixed
                          Pam Johnson

                          I just found the answer; under the "view" menu, the "hide all types" was checked.  When I deselected it, I was able to see and select the origin that I had turned on in the feature tree.  I do have a couple of parts that share the same origin as the subassembly, so using the feature tree to turn on only the one I wanted was how I worked around that.  I just couldn't figure out why the "Hide/Show" items were all grayed out, but found the answer in another thread to uncheck the "hide all types".  The origin isn't the best place to balloon from, but in my case, it will work to turn the leader off (although obviously not a solution for many instances).  I've been looking for a solution for this for hours, and finally have one thanks to your help!  I may end up cheating on this drawing and using text, as there are 86 assemblies I would have to change the settings on, but now that I know how to have them set up from the get-go, it is a solution to use going forward, and as I'm starting our department out on using SWX, everything I can find a way to do before they get to it is a huge help to all 6 of us.  Thanks again, Greg!