3 Replies Latest reply on Jun 2, 2014 2:11 PM by Jonathan Miller

    Can't login to EPDM 2014.  Can't find server

    Jonathan Miller

      So I've installed EPDM 2014 server pieces and I can login as admin from the server just fine.

      I've installed the client pieces on another machine.  That machine can't connect.  When I try to login there is a long pause and an error that says can't find server.  This is really weird because it find the server in the automatic detection in the setup view wizard.  I've switched off all the firewalls, both the server and client are in the same domain.  I'm totally stumped. Any help would be appreciated.

          • Re: Can't login to EPDM 2014.  Can't find server
            Keith Schaefer

            Verify that the database name is correct in the registry keys of the client machine.

             

            HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Applications\PDMWorks Enterprise\Databases\<vault_name>

             

            HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SolidWorks\Applications\PDMWorks Enterprise\Databases\<vault_name>

             

            The archive server is in the same Databases key, verify that one too.  The server ust be on your domain or use FQDN format.

              • Re: Can't login to EPDM 2014.  Can't find server
                Jonathan Miller

                Keith,

                 

                I checked the registry keys and they are correct.  However, I saw that there were keys for dbserver and dbname.  That's when a light bulb went off.  If the EPDM client needs to directly connect to SQL, then I need to change my sql config to allow TCP/IP connections.  Modern verisons of SQL Server have this disabled by default.  Sure enough I enabled TCP/IP on SQL and restarted the service.  Now I can connect!

                 

                Chad, this might fix you too!

                 

                1. Open SQL Server Configuration Manager on your EPDM server. 

                2. In the tree on the left side, navigate to SQL Server Network Configuration > Protocols for MSSQLSERVER

                3. On the right side double click on TCP/IP

                4. Set Enabled to Yes

                5. Restart the SQL Server service (or the whole computer)