3 Replies Latest reply on Apr 7, 2014 1:00 PM by Deepak Gupta

    Macro issue

    Rod Thompson

      Hello,

       

      Last year Jason Kerns and Simon Turner fixed a macro I use for importing points from Excel to SW. Now the macro I use for exporting a 3D sketch to Excel is giving me problems. It has been a while since I last used the attached macro, but it did work with no problems the last time. Any help will be much appreciated!

        • Re: Macro issue
          Deepak Gupta

          You just need to fix the missing libraries under Tools > References.

           

          Open the macro via Tools > Macro > Edit. Now in macro go to tools > reference and uncheck any missing library and select the corresponding one for your version of SW and Excel.

           

          You may also try the attached fixed macro.

            • Re: Macro issue
              Rod Thompson

              I have SW 2014 and MS Office 2007. Not sure what to check/uncheck as I scroll through the list. I tried your fix and got the following error.

               

               

              Capture4.JPG

              This is how it comes up for me under edit:

              macro as is.JPG

                • Re: Macro issue
                  Deepak Gupta

                  I've excel 2010 if that make any difference but other than that macro worked fine on SW2013 and SW2014.

                   

                  Scroll down the list and check if there is any name with missing. If not then save and re-run the macro. Other way would be to start a new macro and then copy paste the codes from this macro to the new one. Go to the reference list in the new macro and check the Microsoft Excel 12.0 one. Save and try running the macro.