Glenn Schroeder

SpaceNavigator driver issue

Discussion created by Glenn Schroeder on Mar 18, 2014
Latest reply on Jul 22, 2016 by Nathaniel Smith

This isn't a question, just an issue that I finally got solved and it might help someone else.  Apparently, 3dConnexion has changed the way their software works.  After installing SW2014, I downloaded the latest driver for my SpaceNavigator.  Manipulating the model with it was still fine, but the buttons no longer worked.  I right-clicked at the top of my screen to turn on the toolbar so I could click on the Mapping Panel to see what was wrong.  No toolbar.  I've been busy, so I put up with it until this morning when I called the number on the 3dConnexion website.  The very helpful and friendly lady talked me through it, showing great patience.  They've changed things with the latest driver.  No more toolbar.  You can go to Start > 3dconnexion > 3dconnexion Properties to get to where you map the buttons, and then you map them to whatever program is active at the time.  And I couldn't get "Zoom to Fit" to work no matter what I tried.  She finally suggested that I just type F directly in the space (the keyboard shortcut for the same function) instead of using the drop-down.  That worked.

 

And it wasn't my issue, but she also said that if SolidWorks and 3dconnexion aren't both the same on "Run as administrator" (both either checked or not checked) it won't work.

 

Anyway, I thought this might save someone else some aggravation.  And I was very pleased with the customer service from 3dconnexion.

Outcomes