5 Replies Latest reply on Mar 7, 2014 12:06 PM by John Burrill

    Why are some parts shaded and others not?

    Mike Mason

      See the pic below.  After much trial and error I can't seem to be able to determine why some of my parts are solid shaded and the others are not.  I'm sure it is some setting in the assembly file. Thanks for any help.

       

      Capture.JPG

        • Re: Why are some parts shaded and others not?
          Brian Rose

          Your display style is set to shaded. Towards the top-middle of your screen you can change your display style.

           

          BR

          • Re: Why are some parts shaded and others not?
            John Burrill

            Mike, it could be the component display is set in the assembly to "Shaded with edges" for that base plate.

            If that's the case, then when you open the assembly and set the viewport mode to HLR or something else, the assembly will look like your drawing view.

            If this is the case, you can fix the situation by doing the following

            Open the assembly

            Select the base-plate component in the assembly tree, right-click and go to "Component Display" in the context menu and change the setting from "Shaded with Edges" to "Default"

            That should make the component follow the global setting.  When you go back into your drawing, it'll be there.

            Coupule of final notes:

            The Component Display setting is active for the current display state only.  If there is more than one display state in your assembly, you'll need to first set active the display state used in the drawing view

            SolidWorks will show a degraded view of the drawing while it's rendering the high-quality views, so if your cursor switches to a frame with a lightening bolt when you mouse over this view and the view doesn't eventually display correctly, that could indicate that your assembly has a circular reference-because the assembly never rebuilds successfully, the view is never fully resolved and displays draft quality.

            If you have 2014, you can toggle high-quality/draft quality for shaded views, although this setting isn't available for HLR views.

            Good luck

            John