10 Replies Latest reply on Jan 19, 2017 5:39 PM by Rick Stockton

    Tangent Lines on in Model, off in Drawing?

    Mark Deboer

      Seems like a stretch but I am tired of switching it 20 times a day. In my part/assembly models I like to use the shaded with edges and have the tangent lines on. Easy to see surfaces on parts with multiple curves. But when I go to do my part/assembly drawings, if the tangent lines are on they come in super think and just look generally bad, so I turn them off and everything looks much better. I notice that when I change it in the system options that affects all of SW, but that doesn't necessarily change it in the view>display>tangent edges. Sometime they get opposite of  each other, one off and other on, and it really makes the drawings freak out. If I have it all set to off everything plays nice, but I'm not totally happy while modeling. I can't remember having this issue before with earlier versions of SW. Anyone else like me and have to constantly turn tangent edges off and on?

        • Re: Tangent Lines on in Model, off in Drawing?
          Glenn Schroeder

          Please check the following settings:

           

          Tools > Options > System Options > Drawings > Display Style > "Tangent edges in new views".  For what you want "Removed" should be selected.

           

          Tools > Options > System Options > Display/Selection > "Part/Assembly tangent edge display".  If you set yours to "As visible", then you can control the tangent edge visibility by going to View > Display > and choosing "Tangent Edges Hidden" or "Tangent Edges Visible".

           

          By the way, you mentioned that your tangent edges in drawings are too thick and look bad.  Those can be set for an entire document by going to Tools > Options > Document Properties > Line Font.  You can set Style and Thickness for many line types.  You can also control individual lines by clicking on them and using the Line Format toolbar.

           

          Let me know if this helps please.

            • Re: Tangent Lines on in Model, off in Drawing?
              Mark Deboer

              Glenn, thanks for the suggestions, they partially helped and may have uncovered real problem.

              I set options to what you suggest and it works but still minor issue. When I bring in view to drawing, it defaults to the hidden lines removed display, what I want, then I change the iso to shaded with edges. Well on all views the edge lines come in thicker than normal. tangent lines still off. If I turn on tangent lines they come in thicker than normal too. With view>display>tangent off, go to system options and turn them off there too, then everything looks normal again, but I lose my tangent edges in my model unless I do view>display>tangent on.

              I initially thought it was a graphics card thing, so I checked for updates and installed a new driver this morning, but that hasn't fixed the problem. Its a Quadro 4000 btw.

              I did go check the line font and the tangent lines are already set to the the thinnest style.

              When system options has tangent edges removed, and I go to view>display and turn them off and on, everything looks and appears normal. Its like they are getting put on there twice when system options has the setting turned on. Is that possible?

              • Re: Tangent Lines on in Model, off in Drawing?
                Mark Deboer

                I found an annoying fix but not a solution. With the settings set like you say, my models have tangent lines and my views in a drawing come in without tangent lines, but the edge lines are way thick. If it toggle realview graphics on and off that seems to make the lines go back to their normal thickness.

                  • Re: Tangent Lines on in Model, off in Drawing?
                    John Burrill

                    Mark,

                    after you insert the view into your drawing is, when you hover your cursor over the view, does it display the draft view icon (little frame with a lightening bolt on it) because until the view is done resolving itself and the lightening bolt dissappears (in 2013 and prior versions) SolidWorks will render the views with tangent edges shown and thick. 

                    draft_quality_shaded_views.png

                    The lines will print according to the view or document settings.  It takes longer to render a high-quality view, so if you can work with a draft quality view, you'll be able to move traverse your drawings faster.

                    In 2014, you can, toggle the view to display high quality or draft quality

                    high_quality_shaded_edges.PNG

                      • Re: Tangent Lines on in Model, off in Drawing?
                        Mark Deboer

                        John,

                        I have SW 2013. When I insert a view I do not see the draft view icon. I dont think I have ever seen it. I notice on your display style on the left of your screen, it gives you the option of draft or high, mine does not. In system options it is set to high quality though.

                        You mention that the drawing will print with the the chosen settings. That is not the case for me. If the view in the drawing has the thick edge lines, it prints with the think edge lines. If I can get them to change to the correct thin lines, it prints just fine. I have to go through all the settings and toggle things on and off to eventually get the lines to show correct and not thick.

                    • Re: Tangent Lines on in Model, off in Drawing?
                      Rick Stockton

                      Thanks Mark! You nailed it.

                      1 person found this helpful
                    • Re: Tangent Lines on in Model, off in Drawing?
                      Mark Deboer

                      I seem to be having some consistency with having the view come in correct if I have the "use pre 2009 tangent edge definition" checked in the document properties. Part/assembly tangent is set to visible and drawing views are set to removed.

                      I did notice that in the line font there are two edge line options, one has (speedpak) next to it. they were set to the size next up from thinnest. I set both of them to thinnest and that didn't change anything. Strange how they could be set where they were and still change in the drawing if I went through the settings and magically got it to appear right. Oh well I guess, hopefully the pre 2009 setting will make everything play nice.