5 Replies Latest reply on Oct 20, 2015 10:48 AM by Ted Wessale

    SolidWorks not responding

    Zach Zimmerman

      Please help, I have been seing an excessive amount of the time lost due to the following message:

       

      SolidWorks 2014 is not responding

       

      Close the program

       

      Wiat for the program to respond

       

       

      After doing some research I'm come to fine that this isn't necessarily a problem with SWX but  with Windows.

      I have nothing running on my machine but Outlook and now I have been sitting and looking at the green circle of WIn 7 spinning with enough time to write this post. If anyone could be of further assistance to help me in discovering more about this problem I would greatly appreciate it.

        • Re: SolidWorks not responding
          Ian Worrall

          Windows defaults to posting that message after only 3 seconds of unresponsiveness.

          Silly Windows.

          • Re: SolidWorks not responding
            John Burrill

            That's a tough problem to diagnose without more specific information.  Hangs can be attributable to every aspect of your computing environment including, hardware, sotware and network and data.

            Tell us as much as you can about the circumstances of the hang:

            Is this file specific?  (goto tools feature statistics to see your rebuild times)

            Are you pulling files across the network?

            Do the problems persist if you log onto your machine as a different user?

            What operations precede the hang-changing view orientation, open/close?

              • Re: SolidWorks not responding
                Zach Zimmerman

                John, I use an external hard drive to work off of in my day to day. I used to have problems with a connection loss as shown in the screenshot below. I moved to an external which solved this network problem. I typically work with "large" assembly models, (350 parts) so there is a certain amount of processing lag. My computer has 8 GB of RAM, i7 @1.73 GHZ. This problem isn't model specific but particularly occurs when larger assemblies are open. I haven't tried to log in as a differnet user to see the results. What is so frustrating is that this problem seems to occur in normal operation such as saving or trying to get SWX to perform certain functions like view mates etc. Another "hang" problem I run into is when you click on a part in the model or a part or feature in the model tree there is the flyout menu that usually appears. 75% of the time I get the "green circle of patience" of win 7 and at other times the flyout menu immediately appears. My mind automatically defaults to " I need a new puter" but want to do adequate research before going down that route. Thanks for any help.

                 

                 

                1_16_13.PNG

                  • Re: SolidWorks not responding
                    John Burrill

                    OK, I'm running 2014 SP2 and for the last few days I noticed it would occasionally lag and hang up and those hangs affected framerates for zooming, panning and rotating the view as well as the responsiveness of other controls.  Today one of the guys at work borrowed the external USB drive that I use for back-ups and SolidWorks was back to its old perky self. Could be that Kaspersky decided to scan that volume-not sure.

                    Anyway, you might try a simple test to see if your external harddrive is the bottle neck.  Pack-n-go an assembly to your internal drive, unlplug the hard drive and see if there's a night-and-day difference.

                    From what you're describing, it sounds like you might have temporary files stored on the remote drive.  SolidWorks unpacks its icons into a temporary folder when you launch it.  So if your drive is occupied by indexing, scanning or other background tasks, that could slow SolidWorks down.