2 Replies Latest reply on Feb 11, 2014 3:42 PM by John Burrill

    Using Step import

    David Dearing

      Hi.  I imported a Step file of a car, which is one big surface in the feature tree (says "Surface-Imported1").  I need to thicken it so I can use it for a flow simulation, but it pretty much won't let me do anything with it.  There are gaps between the individual surfaces, but since it was imported that way, and shows up as only 1 thing, I can't knit it or anything.  What is weird is I can click on the surface and highlight an individual surface, but I can't do anything with it like copy it or move it. 

       

      Attached is a photo of the problem.  Notice that the imported surface is only half of the car, and it let me mirror copy it, and then scale it to proper size.  Also notice that I can click on one "piece" of the surface (in blue), but that piece is highlited on the left as the imported surface- so I can't edit or copy just the blue part.  What I was hoping to do was to click on each "piece" of the surface, duplicate it, move it over a few feet, hide the original imported surface, knit the copied pieces, thicken, and then use that for my flow simulation.  Any help would be very appreciated!  Thanks.

       

      car issue.jpg

        • Re: Using Step import
          Charles Culp

          This task ahead of you is difficult, you were not given a "watertight" model to do a flow simulation. Watertight models are required for flow simulation.

           

          You will have to fill all the gaps with small surfaces, and then knit those to join. Fill Surface is good for doing this to fill in any size hole.

           

          I suggest changing the way your model displays, and turning on show edges. Also, under Tools>Options>System Options>Display/Selection>Show open edges of surfaces in different color. That will make it more clear what is going on, and where all the open edges are. If you do, take another screen shot and post that.

          • Re: Using Step import
            John Burrill

            Dave, before you can do anything with your surface model, you'll need to address those surface gaps and imperfections.

            Given how many patches the model has, I don't envy you that task.

            You should read the online help topics for "ImportDiagnostics ," and Heal Edges

            Final note.  If your step file was created with a specific unit, SolidWorks applies that unit whe constructing the model, so you shouldn't have to scale it.  If your step file was created without units, then you can tell SolidWorks to assume the units of the step file are the same as your document template so that you don't have to add the scale feature.

            This setting is specified in the Import Options dialog box:step_import_units.PNG

            To access thsi dialog, click the "Options" buttun in the Open dialog box after you've selected your step file.

            Good luck.