9 Replies Latest reply on Aug 21, 2014 12:38 PM by Timothy Svirbly

    Welds driving me mad - can't control visibility of beads or symbols

    Ken Lux

      Hi,

       

      I'm using SW 2013x64 SP2.0.

       

      I made the mistake of trying to put welds in a bunch of assemblies with solidworks. To be honest, it would have been easier to mark up the drawings by hand than use this useless feature.

       

      I have no idea how to control the visibility of the weld beads and the weld symbols.

       

       

      1. In drawings, nothing I do can hide the weld beads. Not hide/show/hide weld beads from the view menu, not deselecting/selecting/deselecting welds in the document options->detailing-> display filter
      2. In drawings, the only way to show weld symbols is to import all the design annotations with a parent view, but a bunch of other stuff I don't need shows up to (a bunch of dimensions from parts and subassemblies that are so dense it looks like an ink spill on the drawing view). It appears that there is no way to get weld symbols that are not assigned to a view into a drawing. This is in direct contrast to the help file which says I can select a view and using model items selectively include weld symbols. No weld symbols are ever imported this way.
      3. In the assembly, I can only see some weld symbols when I move my mouse over them. So I can't tell if I've selected all of the weld symbols to move to an annotation view so I can bring them into the drawing (along with all of my dimensions). Uggghhh

       

       

      So why doesn't the Annotation->Model Items->Weld Symbols refuse to bring in weld symbols to drawings?

       

      Thanks,

      Ken