4 Replies Latest reply on Jan 8, 2014 12:32 PM by Patrick Kenna

    Dimensioning a 2D Sketch - problem

    Rolando Venegas

      I have a problem to put a dimension on a 2D sketch. This thing started to happen today after my solidworks 2012 broke down during a "smart fasteners" operation.

      Now when I try to dimension a sketch, as described in:

       

      http://help.solidworks.com/2012/English/SolidWorks/sldworks/Dimension.htm

       

      In the step 2 is said "As you move the pointer, the dimension snaps to the closest orientation."

      But I have not a dimension to move, it only appears at the time when I click in an other site, and I can't move it. Is something wrong with my system configuration?

      Thanks.

        • Re: Dimensioning a 2D Sketch - problem
          Eric Irwin

          I am not sure what you are asking exactly.  Can you try and post some screenshots or something to better describe the issue?

            • Re: Dimensioning a 2D Sketch - problem
              Rolando Venegas

              Thank you Eric, I was working on a sketch. When I wanted to put dimensions, I selected the two points, but the dimension did not eppear, then I click in another place, the dimension I wanted appeared, but I couldn´t drag it or edit it. When I click again a new dimension appeared over the same two points and an overdimension alert appeared.

               

              I was workind on a piece edited in an assembly. Later I started a new piece and the dimension worked normally.

                • Re: Dimensioning a 2D Sketch - problem

                  Hi Rolando,

                   

                  There are lots of things that could affect this.  First, turn off perspective; we have an issue displaying dimension in our "scene graph" when perspective is on. Second, because you mention smart fasteners, are you sure that you are in a 2D sketch and not a 3D sketch?  A screen shot would help.

                   

                  Regards

                   

                  Mark

              • Re: Dimensioning a 2D Sketch - problem
                Patrick Kenna

                Is this te you're having?

                 

                1. I click dimension, I click the first line between the two dimensions.  Note that the ".25" dimension was already there and I selected the horizontal line at the top of the "L".  No dimenion was shown on the screen at that stage.Desktop Capture-01-08-2014 11-16-54.jpg
                2. Next I selected the second horizontal line, the one along the bottom, in an attempt to define the overall height.  Still no dimension has popped into the work screen.Desktop Capture-01-08-2014 11-17-13.jpg
                3. I click the open space to the right of the sketch.  the dimension appears.Desktop Capture-01-08-2014 11-18-38.jpg
                4. Satisfied, I proceed to now click the next object, but the system is still tying to the previous dimension, now it addes a second dimension where I clicked (the vertical short length)

                  Desktop Capture-01-08-2014 11-19-01.jpg

                 

                To summerize, what typically happens is when you click a line or other element, the program will ghost a dimension into place that follows your cursor.  When you select additional elements of the sketch the dimension will adapt to provide the relation between the selected elements.  What's happening to me right now is I select the elements and nothing happens untill I select open space in the sketch, and then it stays locked to the previously selected elements.

                 

                I wish I could record video as this is really ticking me off.  I know there's a control for this but I can't find it in the help files nor the forum.

                 

                -Patrick