6 Replies Latest reply on Nov 5, 2013 5:07 PM by Anna Wood

    Equation entered is invalid

    Scott Rypstra

      Hey guys, I'm really not sure why this equation doesn't work.

      If I hover my cursor over the equation, it even evaluates it correctly, but a little error pops up and says "Equation entered is invalid", and i cannot click OK out of the Modify dimension box

      invalid.png

      Any ideas?

      Thanks

        • Re: Equation entered is invalid
          Mark Kaiser

          Have you tried atn((.75/12)/2) ? Or do you want (atn(.75/12))/2 ? 

            • Re: Equation entered is invalid
              Scott Rypstra

              It's not so much the syntax as it is that I cant even click ok and nothing will happen..a box pops up and says "Equation entered is invalid" and i have to type something else in there--i cant even type in "=1.78"...it's like it doesnt think its and actual equation or seomthing. idk. its weird to me

                • Re: Equation entered is invalid
                  Anna Wood

                  Assuming restarting your computer does not help fix the issue.

                   

                  Did it work before?  If it did what has changed since it worked?  Windows Updates, etc.....

                   

                  Is it just this file?  Can you post your file for us to look at?

                   

                  Cheers,

                   

                  Anna

                  • Re: Equation entered is invalid
                    John Burrill

                    Scott, I've seen this kind of irritating difficulty in the equations dialog box.  Most of the time it happens when I'm defining global variables, but occasionally, it will just bugger on an equation where it won't accept a dimension reference or function.

                    I imagine the same thing can happen if you're entering the equation in the dimension dialog box.

                    Usually, clearing the equation value and exiting the sketch and then recreating the equation in the equation dialog box does the trick.

                    Oh, final thing: I noticed you have a double-quote in the name of your sketch.  That could be tripping up the interpreter since it also reads visual basic expressions.  Try taking that out and see if you can enter the equation as written otherwise.

                      • Re: Equation entered is invalid
                        Scott Rypstra

                        Anna, I tried a restart and it didnt help. Equations do work on other parts, and it looks like it is in fact just this SKETCH where it doesnt work, as John kind of suggested.  i can make equations in other sketches, but not in this sketch. even for other lines in the sketch. i tried deleting all equations in the entire part (in the equations manager too), but i guess it's just this sketch that something messed up on---This is all a pretty minor issue, but i just get waayy too annoyed by things that i think are simple . P.S. it might have to do with renaming dims or sketches or something, but im not sure... thanks anyway everyone.

                         

                        EDIT: BINGO! (i just noticed your edit) That double quote thing was correct! interesting..............