Joe Wilcoxson

Solidworks Electrical 2014 Review

Discussion created by Joe Wilcoxson on Oct 25, 2013
Latest reply on Nov 18, 2015 by Nelson Ouzts

UPDATED 4/3/14 for Service Pack 2 --> See "Update (3/26/14) Service Pack 2.0" title below

 


SWE 2014 SP0

Unfortunately, I would have to say I am disappointed with Solidworks Electrical 2014 so far. It really seems like for every feature that was added, two or three others were broken. I understand that the SP0 release is typically a bit buggy, but I have spent much more time tracing down isssues and finding workarounds than actually designing equipment.

 

First off, the upgrade process was abysmal and had my department down for a whole Friday and me on a Saturday. After performing the upgrade on the server and client machines, we would encounter a bug where the client would try to connect to the server, and eat up all the RAM on the client machine until Solidworks Electrical crashed. Our VAR and Solidworks were unable to figure out what was happening. Ultimately, after spending all Saturday playing around with it, I switched the SQL login on the client from 'tew' to 'sa', connected once, then switched it back and we were good to go. It was that simple, I would guess that the first client to connect had to run something on the SQL server that required the higher 'sa' privileges.

 

Soon after we found that archiving wasn’t working anymore. Anytime we would try to archive a project, it would get all the way to the compression stage and then fail. Again, our VAR and Solidworks couldn’t figure out what was going on. Ultimately, I found that the upgrade has caused several of the symbols in libraries to duplicate, which would cause the SQL stage before archive compression to fail, leading to a failed compression process. Deleting the duplicate symbols brought everything back to normal.

 

A welcome change is the new filter dialog in the Projects Manager. Need to filter down to a project with a specific contract number? No problem, super easy now. It’s a great help for people with hundreds of projects like us.

 

The new storage format for databases in an archive is now SQLite instead of Microsoft Access, which is a bit faster and doesn’t have the compatibility problems that the Access format had.

 

A function has been added that lets you specify the max number of wires that can connect to a given terminal. In theory, you could then run a DRC to find terminals with too many wires connected to them. Unfortunately, this property cannon be set at the Manufacturer Part level, it can only be set after the symbol is placed. This means that instead of having this ready to go from your library, you need to manually set the max number of wires for every single symbol you place, making this feature much too cumbersome to be of any use.

 

One new feature is the much anticipated "Design Rules Checks", which is supposed to check you projects for errors such as symbols without manufacturer parts assigned, cable cores that haven't been used, and components with no schematic symbol. This was really talked up like it was going to be a major improvement, but after checking it out, it’s literally just reports by a different name. Most of the new DRCs are even former reports. The DRC dialog is identical in every way to the reports dialog, with identical functionality. The was absolutely no effort put in to this beyond creating a new button called “Design rules check”.

 

Speaking of reports, the main dialog has been improved a bit (it’s really similar to a mock up I sent up months ago). Gone are the clunky tabs along the top for different reports, replace by a much easier to navigate list of reports on the left hand side. Also new to reports is the ability to generate the report name dynamically. This is really handy for multi-page reports, as the resulting file names can now be “Bill of Materials 1/2, Bill of Materials 2/2” instead of two files both simply called “Bill of Materials”. Formulas such as this have also been added to be able to dynamically generate the User and Translatable data fields for the files. I did notice some inconsistencies here. A blank formula for a User Data field results in a blank User Data field, while a blank formula for Translatable Data leaves the existing field value alone. The latter method is much more preferred. If I don’t specify a formula, it should assume I am going to provide my own field value manually and not overwrite it with a blank string every time I update the report.

 

If you are an advanced user of Reports, you are going to tear your hair out when trying to make a custom report. Be prepared to spend a lot of time in SQL Server Management Studio testing queries and a lot of time in an XML editor hand modifying the report templates. In 2013, when you would change the Sort and Break of a report, it would try and modify your query (many times breaking it completely). The good thing was that it would only attempt this once after changing the Sort and Break. In 2014, it constantly changes your query, and has no clue what to so. You literally need to let the query fail after it breaks it, open the reports XML config, fix it by hand, then pray you don’t have to open the Report Properties dialog again.

 

I not sure if anyone else goes all in on reports like I do, it’s certainly both the most powerful and frustrating feature for a power user. The built in SQL editor is still a complete joke if you have any hopes of formatting your query so it can ever be read again. The built in queries are a complete mess as well, formatted terribly, and impossible to read. It’s clear that they hoped to shotgun the query to get as many fields as possible so the query would have to be touched again. Many times I just write a new query from scratch just so I can have an idea of what’s going on with it. The parsing is also still a joke. There are three versions of your query: the one you see in the SQL editor, the one that exists in the XML config and the true, proper query that gets passed to the SQL server. They are all slightly different, replacing single quotes with brackets and greater than / less than with %gt;%lt;. I can understand the swap of > and < for %gt; and %lt; due to the structuring of XML, but I still find it hard to understand the reason for square brackets instead of single quotes in the SWE SQL Editor.

 

Wire styles are still kind of a mess. If you want to have multiple wire styles in an equipotential, you are going to have a bad time. When you draw wires, you should be drawing an equipotential with a default wire style of you choosing. All wires drawn this way will be of the style, until you go in to the wire order manager and choose the outliers that should be of a different wire style.

 

Unfortunately, it isn’t that simple. Wires still have a wire style (that is very difficult to change), but also have another set of wire properties that is somewhat independent from the wire style. The SQL table tew_wire even shows this. For each wire, there is a wire style field, a gauge field and a color field. Why? This goes against all common sense in a relational database. A wire should only have a style, and that style contains the gauge and color field. Duplicating data like this only leads to inconsistencies. I had to rewrite all of my wire list queries due to the fact that the wires color and gauge fields can’t stay in sync with the wire style field.

 

There are some new bugs introduced as well. When assigning a part to a symbol, there is a high chance that you will end up with several virtual circuits out of nowhere, that need to be manually deleted afterwards. When choosing a different drawing background color in the interface configuration, the new color only stays until you restart SWE.

 

Overall, I would say that it you are on 2013, don’t bother upgrading just yet. There are no major improvements that make 2014 worth it, and the new bugs introduced just make it worse. I can tell that the team working on this had a lot of good ideas and intentions, but fell flat on the execution with a misunderstanding on how something like this should work. I am going to continue using SWE, because I do see how powerful it could be, but it is certainly frustrating to do so with a major release such as this.

 

Update (10/28/13)

I was able to use the 2D Layout Feature for the first time in 2014 today, and it looks like it has recieved some improvements. Inserting a whole terminal strip at once has been fixed (previously came in at an incorrect scale, you needed to insert terminals one by one), components now get a nice wipeout underneath them and units have been shifted from Meters to Millimeters for metric, which is much more approprite for electrical components.

 

Update (10/29/13)

I think I need to vent a bit. I have spent all day fighting bugs in SWE 2014. I can honestly say that I have spent 90% of my time trying to find workarounds or sources of bugs and only about 10% getting anything productive done. I'm about to switch back to AutoCAD LT, because I'm getting so far behind on my projects in SWE. I think my VAR has gone silent on me, maybe they don't know the answers, maybe they are just sick of all the problems I encounter.

 

I can firmly say that the wiring system in SWE is fundamentally broken. The SQL database is full of fields containing redundant wiring data that don't stay in sync, and it's anyones guess as to which field will affect which funciton in the software. Wires get assigned a wire style from the style of the line you draw in the schematic. There is a field in the SQL table that links the individual wire to its assigned wire style. A wire style has properties of color, gauge, AWG, etc. For some unknown reason, the wire table duplicates these fields from the wire style table, and the data goes nuts. Its like saying I have a pet that is a Beagle and a Beagle is a dog, there is no need to also state that my pet is a dog, it just creates redundant data that you need to manage.

 

I got a chance to see our subscription service renewal bill for SWE, and it's really hard to justify the cost right now.

 

Update (12/2/13)

It's been a long, slow month. It has gotten better recently though, however this is not to the softwares credit. The only thing we have done is figured out how to better work around the issues with the software.Some of my guys have taken to having me manually override wire styles in the SQL server, because SWE just can't come to terms with the fact that you could have two different types of wire at the same potential. Want to have a White 16AWG neutral wire and a Green 14AWG ground wire at the same terminal of a transformer? Nope, no way to reliably do that through the software.

 

Service Pack 1.0:

I recently tried to install this on my desktop (which has a standalone SWE install), and it went pretty poorly. It first instructed me to kill the SQL Server Process, which I did. Next it provided me with a nice error message stating that it couldn't update SWE to SP1 because it couldn't locate the SQL Server. Well, obviously it couldn't because it just told me to kill the process.Currently attempting a repair and reinstall.

 

Note: The installer in 2014 seems to have killed the Server-Client paradigm of pre-2013 and elecWorks. It's still possible to have a server-client install, but it's not as easy as it used to be.

 

Update (12/17/13)
I did get SP1 working after a repair and reinstall, but it turned out to be a big dissappointment. Still seems to have some major issues. After much discussion with Solidworks, they decided to have us roll back to 2013SP5 until 2014 is to an acceptable level. We spent the past three business days at a stall while they downgraded our projects to 2013SP5. While it was pretty annoying to be down, I can say that the support team at Solidworks worked really hard to make sure we were taken care of, which I greatly appreciate.

 

My ultimate recommendation for Solidworks Electrical 2014 is a firm do not buy / do not upgrade. Here's to hoping SP2 will be the hero we need.

 

Update (3/26/14) Service Pack 2.0

After quite some time, we finally took the dive and upgraded to 2014 SP2. After several months on 2013 SP5, which is very stable, it was time to try an upgrade. After several hours with the software, it appears as if it is at least as stable as 2013 SP5 was.

 

My initial impressions are as follows:

 

The Good

-The Reports Manager dialog has been cleaned up a bit. The reports are now listed as a list on the left side of the dialog, instead of tabs accross the top. This is a great usability improvement for those of us who have several reports in a single project.

-Automatically generated Report Titles bases on formulas is nice, as it allows you to have multipage reports end in "1/2" or "2/2" for better identification.

-Paste Special is awesome, now you can easily copy and past circuits between projects without forced renumbering of the components. Using Paste Special, you now can control the resulting marks of what you paste in.

-Design Rules Checks - While these are still just a different wording for reports, it is nice that there is now a separate area where you can create reports to tell you where you might have messed up.

-Wire Labels - There is now a way to label wires in the schematic with their wire color, gauge, etc. This is a great feature for projects with a small amount of wires. A block will be inserted over the wire and can identify properties of the wire of your choosing. Unfortunately, it looses much of its luster on large projects with many wires, and doesn't work at all when a wire path contains multiple wires of a different wire style.

 

The Bad

- If you are really heavy into creating custom reports via SQL, the changes to the Report Template Manager dialog will drive you insane. It constantly will attempt to rewrite your query, breaking it 9 times out of 10. The only workaround is to go to the XML file directly and modify the SQL query there. This was a slight issue in 2013, but much more pronounced in 2014.

-EPDM integration still isn't quite right. A second style workflow was added, which allows you to Check Out/In from your EPDM Vault. While I was able to get it to successfully Check Out a project to the Projects Manager dialog, and even Undo Check Out, it was not able to successfully able to Check In the project. The EPDM Integration still requires a VERY specific EPDM folder structure for your SWE Projects, and if you have existing projects in your vault that don't conform to this, forget about EPDM integration entirely. I could see how it would be useful for those with brand new EPDM installs and very few projects, it doesn't work for the existing EPDM users with several projects.

 

Overall, I can say that 2014 SP2 is the first 2014 release that is a true upgrade to 2013 SP5. While EPDM Integration still isn't quite there, they are at least moving in the right direction, once it can work with existing vaults without heavy modification to the vault structure and can write in Revision Table / Variable info to the EPDM file, I will be very happy. The Report thing is a pain, but I don't think many people go as deep into reports as I do, so I'm betting it only affects me. I imagine it will be fixed before the user base gets really big and real power user begin to show up.

 

I  can say that Solidworks has been very receptive to my comments and has really showed interest in what improvements I may have for the software.They schedule time to meet with me every few weeks to discuss what I have found and we do screen share where I show specific functions of the software and how I think they could be improved. Of course, everyones workflow and needs are different, so a huge issue to me could be very minor to another user. While I am very hard and critical on the software, it stems from a desire to make the software better. Everytime I run into major issues with SWE, I try out other ECAD packages. You know what? They all suck. AutoCAD Electrical, with all the weight and clout that comes with the Autodesk name.... sucks. It has a few nice features that SWE is missing, but thats probably due to a several year head start on SWE/Elecworks. At least with SWE I know they will listen wo what I think sucks about it. Several features I have requested have actually made it in to the software, and it's a great feeling. I asked and they listened and improved. You won't find that with many other companies.

 

Update (4/3/14) - Impressions of 2014 SP2 After a Week

So far, so good. We haven't encountered any game breaking bugs, and it seems to be pretty stable. It's really a shame the EPDM integration isn't quite right yet, because I would be super happy with this release if it was.

 

More Good Stuff

-If you are like me and specify specific guage/color/temp rating of wire in you wire styles, then you have been undoubtedly been struggling a bit with SWE. Up until now, mixed wire styles in an equipotential were a nightmare. No matter what you tried, it was always a struggle to get everything to some out right. In 2014 SP2, the wire style of any particular wire is always pulled from the wire style of the line at the connection point of the origin component. This finally makes the resulting wire styles predictable, and while it isn't a perfect solution, it certainly makes things much easier. This makes one of my biggest complaints about SWE go away.

 

-Wire Labels - While the symbols don't have all the possible attributes available, and wire labels are all but useless on huge projects with mixed wire styles, they certainly are useful for small projects with simple wiring and can eliminate the need for a wire listing.

Outcomes