AnsweredAssumed Answered

Solidworks 2013 SP4.0 installs, uninstalls immediately afterward.

Question asked by Derek Mullin on Sep 12, 2013
Latest reply on Sep 16, 2013 by Chris Challinor

I am attempting to install Solidworks 2013-2014 SP4.0 from an administrative image created with the SolidWorks Installation Manager.  Installation is via the command line on Windows 7 64-bit.  The machine previously had Solidworks 2012-2013 on it, but this has been uninstalled.

 

The command line, per instructions on the website, is in the form of:

 

msiexec /i "64-bit_admin_image_path\SolidWorks\SolidWorks.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks,SolidWorksToolbox /qb

 

(Where "your_folder" and the serial number have been customized accordingly.)

 

The installation runs its course, with files appearing in the directory that I specify on the command line, and then at one point the progress bar begins moving backward, the files are deleted from the directory.  Seems like it installs and then uninstalls immediately.

 

I'm currently combing through the installation log (via msiexec /lvx) for more info, but this is what's at the very end:

 

MSI (s) (8C:7C) [13:42:30:536]: Error in rollback skipped. Return: 5

CustomAction RollbackUnReg_DocMgrDLL.A48C1CF2_EBF8_48E8_ACAD_68CA04F776A2 returned actual error code 3 but will be translated to success due to continue marking

MSI (s) (8C:7C) [13:42:30:536]: Note: 1: 2318 2: 

MSI (s) (8C:7C) [13:42:30:536]: No System Restore sequence number for this installation.

MSI (s) (8C:7C) [13:42:30:536]: Unlocking Server

MSI (s) (8C:7C) [13:42:30:614]: PROPERTY CHANGE: Deleting UpdateStarted property. Its current value is '1'.

Action ended 13:42:30: INSTALL. Return value 3.

MSI (s) (8C:7C) [13:42:30:630]: Note: 1: 1708

MSI (s) (8C:7C) [13:42:30:630]: Product: SolidWorks 2013 x64 Edition SP04 -- Installation operation failed.

 

MSI (s) (8C:7C) [13:42:30:630]: Windows Installer installed the product. Product Name: SolidWorks 2013 x64 Edition SP04. Product Version: 21.140.70. Product Language: 1033. Manufacturer: SolidWorks. Installation success or error status: 1603.

 

MSI (s) (8C:7C) [13:42:30:661]: Deferring clean up of packages/files, if any exist

MSI (s) (8C:7C) [13:42:30:661]: MainEngineThread is returning 1603

MSI (s) (8C:84) [13:42:30:661]: RESTART MANAGER: Session closed.

MSI (s) (8C:84) [13:42:30:661]: No System Restore sequence number for this installation.

=== Logging stopped: 9/12/2013  13:42:30 ===

 

MSI (s) (8C:84) [13:42:30:661]: User policy value 'DisableRollback' is 0

MSI (s) (8C:84) [13:42:30:661]: Machine policy value 'DisableRollback' is 0

MSI (s) (8C:84) [13:42:30:661]: Incrementing counter to disable shutdown. Counter after increment: 0

MSI (s) (8C:84) [13:42:30:661]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2

MSI (s) (8C:84) [13:42:30:661]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2

MSI (s) (8C:84) [13:42:30:661]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1

MSI (s) (8C:84) [13:42:30:661]: Restoring environment variables

MSI (s) (8C:84) [13:42:30:676]: Destroying RemoteAPI object.

MSI (s) (8C:4C) [13:42:30:676]: Custom Action Manager thread ending.

MSI (c) (58:E4) [13:42:30:676]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1

MSI (c) (58:E4) [13:42:30:692]: MainEngineThread is returning 1603

=== Verbose logging stopped: 9/12/2013  13:42:30 ===

 

Has anyone else encountered this?

Outcomes