7 Replies Latest reply on Sep 22, 2014 8:13 PM by Umesh Patel

    DXF export from Solidworks gives alwas imperial paper space size.

    Umesh Patel

      Hi Guys,

      I am new to Solidworks,

      I recently created my first drawing in Solidworks,

      Than I exported dxf, I choose the following export settings,

      but when I open the file in draftsite, what I notice is the drawing paper space size is set to imperial,

      and the paper space would not fit to actul drawing border,after ward I can correct this in draftsite but it will be good to get it correct by default.

      I tried to export many times but this will not go away, and every time I choose some metric sheet size in solidworks , I get imperial paper space size in dxf

      I checked in solidworks my drawing options are set to ISO standard.

       

      does any one has faced similar problem and have solution for this one?

       

      Thanks.

      dxfexportsettings.png

      imperial.png

        • Re: DXF export from Solidworks gives alwas imperial paper space size.
          Jan Forkovic

          Hi,

          Print Configuration Manager can not read the size of the drawing from dwg or dxf file. You must first create a custom configuration files for each dimension of drawings. They are stored as "cfg" files. For example A1.cfg, A2.cfg etc. If you print a drawing A1, you must load A1.cfg.

          • Re: DXF export from Solidworks gives alwas imperial paper space size.
            Jake Brann

            I have the same results.  When saving to dxf, I get on paper space sheet with the drawing entities off the plot size.  Additional sheets don't have this issue.  I don't know what drives this whether it is a setting in Solidworks or Autocad.  Anyone have any further thoughts?

             

            sheet2.PNGsheet3.PNG

              • Re: DXF export from Solidworks gives alwas imperial paper space size.
                Ethan Kay

                Umesh & Jake,

                The issue that you are seeing with paper space being very small compared to the drawing is because the dxf file is set to mm based on the Solidworks units in the file properties tab under options.  DraftSight paper space is set by the printer configuration file to inches this scales the drawing 25.4:1.  As Jan said, you need to create a print configuration files in DraftSight with the units set to millimeters.  This will change the units of the paper space and resize sheet to properly fit the drawing.

                  • Re: DXF export from Solidworks gives alwas imperial paper space size.
                    Jake Brann

                    I agree it is off by a scale of 25.4 - but creating plot configs can fix the problem once the file is opened in the dwg/dxf program.  But I am trying to figure out why it is incorrect in the first place.  I have tried to change the settings in Solidworks and Autocad to fix but so far have not had any success.

                     

                    I have the dxf/dwg export options set to: Capture.PNG

                     

                    the file created has sheet1 (paper space) set to imperial units: Capture.PNG

                     

                    the following paper space sheet is metric: Capture.PNG

                     

                    and of course sheet 1 is off the paper since it is off by a scale of 25.4.

                     

                    What is driving this setting?

                     

                    Jake

                      • Re: DXF export from Solidworks gives alwas imperial paper space size.
                        Ethan Kay

                        Jake,

                        You haven't changed your units to mm in draftsight which is why the plot size still reads "23.39x16.54 inches". 

                         

                        DXF files do not contain metadata for setting the units in the program that it is being opened by, so the drawing is coming in as 594x420 (no units) and draftsight is saying "I'm going to just assume those are inches because that's what I'm set to recognize". 

                         

                        Also I opened your dxf file and it looks like your border is much smaller than the paper size so in the lower right of the box below you should use the print offset command to possition it where you want on the paper.

                        DS-mm-settings.png

                          • Re: DXF export from Solidworks gives alwas imperial paper space size.
                            Umesh Patel

                            Thanks Guys,

                            I think I was able to solve this,

                             

                            Go to C:\Users\"username"\AppData\Roaming\DraftSight\1.2.231\Template

                            step: 1

                            rename the existing standard.dwt to standardOLD.dwt ( this will remove the existing  inch template)

                             

                            step: 2

                            copy the standardiso.dwt and give a name standard.dwt ( this will put new metric template as default).

                             

                            _______________________________________________

                            now when you open the dxf exported from solidworks it should come with default units of metric.

                            the other thing you might need to do is to define a new print settings for the metric units

                            should be stored in

                            C:\Users\"username"\AppData\Roaming\DraftSight\1.2.231\Print Settings