4 Replies Latest reply on Sep 9, 2013 5:31 AM by Ropanzer Romania

    Mixed mesh solid shell with solid

    Ropanzer Romania



      I have some problems with this assembly, first I made an mixed mesh solid with beams it works only for several time, and then I tried shell with solid and it give this error : Surface to surface contact: Sorce surface/edge is not defined properly


      Could you please help my with this Simulation study 7 , the assembly is in the rar file .



        • Re: Mixed mesh solid shell with solid
          Ropanzer Romania

          I made a new assembly with only 2 component (1 solid, and 1 made with beams and solids).

          The first study I made with global contact set to bonded, and it works every time.

          After, I made another study with global contact set to bonded and with No Penetration Contact Set (solid to solid) it works fine! but when I rerun the simulation it give this error: Beam is not properly bonded to shell/solid. Bond 0.

          I repeated this study creating an new assembly again and again and with the same forces, the same contact condition and when I run the simulation for the first time, works with no problems!, but when I rerun the study (without changing anything) it give that error, every time.


          I'm busy with this assembly for 1 week and I getting crazy...My SolidWorks 2013 SP4 has an problem. bug?


          Please Help


          I uploaded the new assembly.

            • Re: Mixed mesh solid shell with solid
              Jared Conway

              so the workflow that causes the issue is

              setup the problem

              run the analysis

              let it complete

              then run the analysis again and it fails eventhough you didn't change anything?


              why would you need to rerun the analysis if that is the case?


              also, i didn't look at the first problem, is that something you're still having trouble with as well?


              what i can tell you is that when i use the automatic solver, it chooses the iterative solver and the analysis runs. if i chose the direct solver (which is what your assembly came with) it fails with that error. so i have a feeling that something changed between your first run and the second which also changed the solver.



              is the error a bug? hard to say, you should narrow down what contact causes the problem. with that said, i see a bunch of questionable contacts. some beams that are not connected where i would expect them to be and some contacts between beams and solids tht i'm surprised the software is accepting. i'd dig into your model a bit and make sure where you're connecting 2 different idealizations that they are working as you expect.