8 Replies Latest reply on Aug 26, 2013 10:49 AM by Anna Wood

    how to stop solidworks sucking the memory or not dumping cache?

    Garth Walton

      I AM RUNNING THE SOFTWARE IN LARGE ASSEMBLY MODE, DESIGNING AN INJECTION MOLD , SWORKS JUST GETS REALLY SLOW, I AM RUNNING AN 8 CORE CPU MACHINE WITH 8G OF RAM, AS WELL AS A 1G DDR5 GRAPHICS CARD , SO I DONT THINK IT IS THE RAM OR MAYBE I NEED MORE?!! I DONT THINK IT WOULD BE THE CORE ISSUE AS SW ONLY USES THE MULTI CORES IN SKETCH AND SOME OTHER FEATURES

        • Re: how to stop solidworks sucking the memory or not dumping cache?
          Anna Wood

          That is not what I would consider a large assembly from a memory usage perspective.  That is using only a half a gig of ram.

           

          How is SolidWorks getting slow?  What tasks/actions are slow?

           

          What video card are you using?  Are you using an approved gpu driver?  What CPU model is in your system?  What brand and model of computer do you have?

           

          How many parts are in your assembly?

           

          Can you post a screenshot of your mold design?

           

          Cheers,

           

          Anna

            • Re: how to stop solidworks sucking the memory or not dumping cache?
              Garth Walton

              Mhi there Anna

              that is just my thoughts too, i was just editing a sketch and as i am going out it just hangs for about a minute, everytime i edit a part and accept there is that hanging as it does its calculations i would be expecting it to crunch it much faster. it is not a real big assembly too,

               

              My cpu is an AMD FX 8 4ghz , the gpu is an AMD Radeon HD 7750 series 1G DDR5 on a Gigabyte motherboard , the OS is Windows 7 Professional 64bit, this is a built pc, not a brand name pc, it is brand new, attached are the images of my assembly the moving and the fxd halves, cheers Garth 000130.jpg000131.jpg

                • Re: how to stop solidworks sucking the memory or not dumping cache?
                  Anna Wood

                  In your Windows 7 Power Options make sure it is set for High Performance.  Windows 7 installs with a Balanced Power profile out of the box.

                   

                  With SolidWorks launched but no models opened go into the Tools > Options > System Options > Performance and toggle on Use Software OpenGL.  This will bypass your video card.  Then open your assembly and see if it stops hanging.

                   

                  Your performance will be somewhat slower because the cpu will be processing the graphics display on screen. What you are looking for is to see if the hang stops.  If it does that will show that your issue is with the non-approved Radeon gpu.  SolidWorks needs Quadro's or FirePro video cards for optimum performance, not gamer cards.

                   

                  After you have done this test. Again lauch SW with no documents open and toggle off Software OenGL.

                   

                  Are you sure you do not have a circular reference in your assembly that is causing an extended model rebuild everytime you make a change?

                   

                  Go into Tools > Assembly Visualization and set it to look for SW-Rebuild time of each component.  Also look at Tools > AssemblyXpert and see what it reports.  If any of your part show a long rebuild time you will want to investigate them more to see what the issues are with them.  In part files you can look at Tools > Feature Statistics to see what features are taking a long time to rebuild after a Control-Q rebuild.

                   

                  If you would like to have someone look at your assembly offline drop me an e-mail and I can setup a Dropbox share for you.  I can take a look at your files on my computer to see if I have the same issues.  Or get with your SolidWorks reseller and work with them to trouble shoot your issues.

                   

                  AsmViz.png

                   

                  Cheers,

                   

                  Anna