11 Replies Latest reply on Aug 9, 2013 4:32 PM by Jared Conway

    Help on Failed Global Contact Search

    Justin Strempke

      This may be a short/stupid question, or something way over my head, but can anyone help/explain the error message "Failed global contact search"?  This seems to come up quite a bit, and I have models with lots of no-pen surface contacts and it really gets old picking them manually.  I can't find any reasoning for the error, but thought it may have to do with my assembly having patterned parts (sometimes mirror features give my mesh heck, so thought it may be along the same lines).  So I did a copy assembly and dissolved the pattern, but same results.  There's no .out generated that migh give more details either.  Can anyone shed some light on this please?

        • Re: Help on Failed Global Contact Search
          Jared Conway

          have you checked the solidworks KB? i did a quick check and didn't find anything

           

          my guess would be that you have some bad geom or your mesh sizes aren't very compatible.

           

          would narrow down the exact interface that is causing the problem and thne troubleshoot from there.

           

          might also be workflow related...assuming this is happening on a specific model and not all models (software issue), what steps are you taking to do the search? also, if they are all touching at the begining of the analysis, why not use global contact no pen?

            • Re: Help on Failed Global Contact Search
              Justin Strempke

              I looked in the KB, and found this one:

               

              #623872

              Static analysis with global no penetration contact fails with error 'Automatic global contact search'

              Fixed in:

              2012 SP01

               

              Didn't seem fixed in the versions I was using, though I started with 2012 SP3.0 so maybe it reverted...

               

              For the instances I see it (that I can recall), I have mesh control on both faces to be about the same size, and have tried manually checking surface-surface contact.  The geometry *should* be fine, as they all solve fine when I go through and pick contact sets by face manually.  Component contact doesn't seem to work either, even if I only select the majority of the parts in contact then do the faces of the rest manually (so as to split up and not try and have SWX assume global), I get the same error.

               

              I'd love to have the global no-pen work, but that's the underlying issue - it doesn't work so I have to select faces manually.  Only global bonded seems to work.  As far as the steps for the search, I'm not certain what goes on there.  I mesh, verify, then hit Run and SWX shoots me that error within the first minute or so.  I've had the same issue with 2012 and 2013, so don't think it's a bad install or anything.

               

              I've tried setting a global contact to bonded and allow pen, then locally doing component contact for no penetration, as well as adding friction in any and all combination but get the same error.