Toft Bill

Strange SolidWorks behaviour -- solved!

Discussion created by Toft Bill on Jul 28, 2013

I spent the last few weeks getting very frustrated but I finally solved my problems so I wanted to share my experience and hopefully this will help others.

 

My setup:

  • Laptop with Windows 7 Professional x64
  • SolidWorks 2013 Professional x64 SP4
  • SolidWorks 2014 Beta2 x64
  • Home LAN
  • Default browser is Firefox but Internet Explorer also installed

 

My problems (all of these started in the last few weeks -- everything was OK before that):

  • SW2013 could no longer use Web help ("network not available")
  • SW2013 could access Customer Portal (Firefox starts) & User Groups (IE10 starts), but NOT Discussion Forums ("network not available"). However I could use my browser to access these forums.
  • SW2014 installed OK but I could not do Network Acitivation ("network not available")
  • I did email activation of SW2014 and saw the succesfully activated products screen, but then SW2014 stopped. When I retsarted SW2014, I had to do email activation all over again, then SW2014 stopped.
  • I could no longer access my networked printers, but I could see them on the Wndows 7 network map. Reinstalling via TCP/IP address failed. ("no device at this address")
  • WIndows Update stopped working, and I could not manually start the windows update Service.

 

I tried all the usual things: firewall settings, did clean unisntall & reinstall of SW, checked for disk errors, memory error, malware, etc. I was about to do the last resort (WIndows Restore from last known good backup), when I decided to ask my PC techy friend his ideas.

 

He said that because these were all network-related problems, I should  first try resetting my TCP/IP stack to get evrything back to their defaults (duh?).

I found this Microsoft link with the instructions: http://support.microsoft.com/kb/299357

I have attached the screenshot. (I also did a Winsock reset at the same time).

 

After a reboot, EVERYHING WORKS.

  • When I started SW2014, I was able to do the network activation and it then started SW2014 normally.
  • SW2013 could now use Network Help and access the Discussion Forums.
  • Windows Update works & I was able to re-install my network printers.

 

So if any of you are tearing your hair out, this is one (painless) solution to try out.

Outcomes